INFORMATION & COMMUNICATION TECHNOLOGY

STANDARD

GOVT. OF KERALA
General Education Department

Prepared by
IT@School Project for State Council of Educational Research and Training (SCERT), Kerala
2012
National Anthem

Jana-gana-mana adhinayaka, jaya he
Bharatha-bhagya-vidhatha.
Punjab-Sindh-Gujarat-Maratha
Dravida-Utkala-Banga
Vindhya-Himachala-Yamuna-Ganga
Uchchala-Jaladhi-taranga.
Tava subha name jage,
Tava subha asisa mage,
Gahe tava jaya gatha.
Jana-gana-mangala-dayaka jaya he
Bharata-bhagya-vidhata.
Jaya he, jaya he, jaya he,
Jaya jaya jaya, jaya he!

Pledge

India is my country. All Indians are my brothers and sisters.
I love my country, and I am proud of its rich and varied heritage.
I shall always strive to be worthy of it.
I shall give respect to my parents, teachers and all elders and treat everyone with courtesy.
I pledge my devotion to my country and my people.
In their well-being and prosperity alone lies my happiness.
Dear Children,

Information and communication technologies (ICTs) have become so pervasive that we cannot imagine a world without them. The growth of ICTs means that our grip on the world’s facts is increasingly becoming stronger. It is necessary that we cope with this speed of change. It is by keeping in mind this need that the ICT Text book for Class X has been prepared.

In this book you will find the first lessons in graphic designing and also how to animate pictures as per your own script. You will also get introduced to database management, which is in fact a logical continuation of studying ‘office’ tools.

We have been familiarising with the various aspects of Python programming over the last couple of years. This text book has more exercises which will help you write more programmes using the language. While you use various software applications and do programming, you may seek to know more about the machine that computer is and its operations. Therefore, we have included sections on the hardware aspects and networking too.

We have understood about web pages and web sites. What about preparing a website for your school? The chapter ‘A Website for Us’ introduces certain software applications that help you handle the content and design of web sites well.

You must have seen India’s and Kerala’s maps. But how many of you would have seen your panchayat’s map? Scientifically prepared maps are needed for local level development planning. We have a chapter on ‘QGIS’ software that helps in preparing comprehensive resource maps. Simulation software Stellarium and mathematical software Geogebra are also included.

Practise the activities given in this text book and make your own contributions to the ICT field.

Wishing you all success

Prof. K.A. Hashim
Director
SCERT
# Textbook Committee

Information & Communication Technology

## CHAIRMAN

K. Anvar Sadath  
Executive Director  
IT@School Project

## Members

<table>
<thead>
<tr>
<th>Name</th>
<th>Position</th>
<th>Project Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sankaradas. K. V</td>
<td>District Co-ordinator</td>
<td>IT@School Project, Malappuram</td>
</tr>
<tr>
<td>Shanavas. K</td>
<td>Master Trainer</td>
<td>IT@School Project, Palakkad</td>
</tr>
<tr>
<td>Pradeep Kumar Mattara</td>
<td>Master Trainer</td>
<td>IT@School Project, Malappuram</td>
</tr>
<tr>
<td>Hassainar Mankada</td>
<td>Master Trainer</td>
<td>IT@School Project, Malappuram</td>
</tr>
<tr>
<td>Sabarish. K</td>
<td>Master Trainer (Co-ordination)</td>
<td>IT@School Project, Malappuram</td>
</tr>
<tr>
<td>Babu. V. K</td>
<td>Master Trainer (Co-ordination)</td>
<td>IT@School Project, Kuttanad</td>
</tr>
<tr>
<td>Muhammed Abdul Nazar</td>
<td>Master Trainer</td>
<td>IT@School Project, Kozhikkode</td>
</tr>
<tr>
<td>Muhammed Aslam</td>
<td>District Co-ordinator</td>
<td>IT@School Project, Alappuzha</td>
</tr>
<tr>
<td>Vasudevan. K. P</td>
<td>Master Trainer</td>
<td>IT@School Project, Thrissur</td>
</tr>
<tr>
<td>Tony Antony</td>
<td>Master Trainer</td>
<td>IT@School Project, Kottayam</td>
</tr>
<tr>
<td>Harikrishnan. R. S</td>
<td>Master Trainer</td>
<td>IT@School Project, Trivandrum</td>
</tr>
<tr>
<td>Pramod. K. V</td>
<td>Master Trainer</td>
<td>IT@School Project, Malappuram</td>
</tr>
<tr>
<td>Rajesh. K. O</td>
<td>Master Trainer (Co-ordination)</td>
<td>IT@School Project, Kuttanad</td>
</tr>
<tr>
<td>Babu. V. K</td>
<td>District Co-ordinator</td>
<td>IT@School Project, Kozhikkode</td>
</tr>
<tr>
<td>Abdul Hakkim</td>
<td>Master Trainer</td>
<td>IT@School Project, Malappuram</td>
</tr>
</tbody>
</table>

## Translation

<table>
<thead>
<tr>
<th>Name</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sajith Sukumaran</td>
<td>Consultant (Development Communication)</td>
</tr>
<tr>
<td></td>
<td>Thiruvananthapuram</td>
</tr>
</tbody>
</table>

## Illustrations

<table>
<thead>
<tr>
<th>Name</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suresh. E</td>
<td>Cartoonist, Pallikkara</td>
</tr>
<tr>
<td></td>
<td>Kozhikkode</td>
</tr>
</tbody>
</table>

## Co-ordinator

<table>
<thead>
<tr>
<th>Name</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>T. A. Ravisankar</td>
<td>Academic Officer (ICT)</td>
</tr>
<tr>
<td></td>
<td>IT@School Project</td>
</tr>
</tbody>
</table>
Contents

1. The Beautiful World of Pictures ....................... 07-15
2. New Methods of Data Analysis ............................ 16-24
4. Computer Language ..........................................36-47
5. The Machine Called Computer ...........................48-60
6. Let Us Give Life to Sketches ..............................61-71
7. Let Us Share Information ...................................72-80
8. A Website for Us .................................................... 81-93
9. World in Your Palms .............................................. 94-107
CONSTITUTION OF INDIA
Part. IV A
FUNDAMENTAL DUTIES OF CITIZENS

ARTICLE 51 A

Fundamental Duties - It shall be the duty of every citizen of India:
(a) to abide by the Constitution and respect its ideals and institutions, the National Flag and the National Anthem;
(b) to cherish and follow the noble ideals which inspired our national struggle for freedom;
(c) to uphold and protect the sovereignty, unity and integrity of India;
(d) to defend the country and render national service when called upon to do so;
(e) to promote harmony and the spirit of common brotherhood amongst all the people of India transcending religious, linguistic and regional or sectional diversities; to renounce practice derogatory to the dignity of women;
(f) to value and preserve the rich heritage of our composite culture;
(g) to protect and improve the natural environment including forests, lakes, rivers and wild life and to have compassion for living creatures;
(h) to develop the scientific temper, humanism and the spirit of enquiry and reform;
(i) to safeguard public property and to abjure violence;
(j) to strive towards excellence in all spheres of individual and collective activity so that the nation constantly rises to higher levels of endeavour and achievement.
(k) who is a parent or guardian to provide opportunities for education to his child or, as the case may be, ward between age of six and fourteen years.
You know how to make a collage using GIMP software. You also know that GIMP is appropriate software for making posters.

Haven’t you seen daily use products carrying the logos of the companies that make them? Various institutions have their emblem or logo displayed in their premises. Can you download the logo of the IT@School Project under the Department of Education, enlarge it and see? Does the logo blur when you make it bigger? Can you think of the reason for this? This is a problem that we face when we engage in such creative work. Increasing the size of a picture blurs it. Have you heard of mechanisms used for manipulating pictures without losing their clarity? Read the following note, discuss among yourselves, and reach a conclusion.

**Raster and Vector**

There are two ways of recording pictures in a computer – either as Raster files or as Vector files. In Raster files, the colour of every point on the picture is recorded. In these files, a picture is divided into numerous squares. For example, consider a picture with 10 cm length and 8 cm breadth. This picture could be divided into 1000 parts along length and 800 parts along breadth. Then the area of each of the squares would be 0.01 square mm. These squares, which are the smallest elements of a Raster file, are called Pixels (from ‘Picture Elements’).

Suppose we want to print such a picture. The quality of the printed picture will depend on the number of pixels within a given area. In the above-mentioned picture, there would be 100 parts in each centimetre. In other words, we could say that the picture has a size of 100 dots per centimetre. However, traditionally the size is usually mentioned in dots per inch (dpi). We can decide the dots per inch that we require in a picture that we handle. By increasing the dpi
we can enhance the clarity and beauty of the picture. For better print quality, we need pictures of higher dpi.

When we draw a line in a Raster file, what the composer does is colouring the squares along that line. When we enlarge the picture, the squares get enlarged as well. You can view this while enlarging a picture in GIMP.

In a Vector file, it is only the colour of lines and the coordinates of the end points that are recorded in the computer. When the picture appears, the computer will interpret the coordinates of end points and interpolate to mark all the points that fall between. When a picture stored as a Vector file is enlarged, new points get marked in the enlarged surface. As more points are added along with enlargement, the clarity of the picture remains. Vector files store pictures as geometric shapes such as lines, squares, circles and arcs.

Pictures drawn using GIMP software are Raster images composed of pixels. But Inkscape stores images as Vector files. This means that Inkscape remembers geometric shapes drawn in it in terms of mathematical formulae. This is why Vector images are able to maintain clarity and beauty when enlarged as well.

**Enlarge Pictures without Losing Clarity**

Now we know the properties of Raster and Vector images. We need special purpose software to construct and edit pictures without losing out on clarity. Open Office Draw, Coral Draw, Inkscape, Adobe Illustrator, Dia etc., are software applications used for making Vector images. Among these, Open Office Draw, Inkscape, and Dia are open source software.

Let us now see how to make pictures using Inkscape software. Select *Inkscape Vector Graphic Editor* from Graphics menu.

Observe the Inkscape window (Picture 1.1). Find out the similarities and differences between Inkscape and GIMP and fill up Table 1.1.

![Inkscape window](image)
The Beautiful World of Pictures

Similarities

- Various tools and canvases are available
- ............................................
- ............................................
- ............................................
- ............................................

Differences

- Tools and canvases are in the same window in Inkscape. They are in different windows in GIMP.
- ............................................
- ............................................
- ............................................
- ............................................

Table 1.1

Remember the tools that you have used in GIMP. Are all of them available in Inkscape? Do you see any tool in Inkscape which was not available in GIMP? You know about GIMP tools from your previous class. Now let us take a look at Inkscape tools. Bring mouse pointer above the tools that are numbered and identify their names. Try using each tool and tabulate their uses. (Table 1.2).

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Selection Tool</td>
<td>For selecting an Object</td>
</tr>
<tr>
<td>2.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>3.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>4.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>5.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>6.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>7.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>8.</td>
<td>...............</td>
<td>............................................</td>
</tr>
<tr>
<td>9.</td>
<td>...............</td>
<td>............................................</td>
</tr>
</tbody>
</table>

Table 1.2

Activity 1

Constructing a Logo

What is shown in Picture 1.3 is a logo constructed in 600X150 pixel size. Let us construct the same logo using Inkscape software. Think about the various tools that could have been used in constructing this logo? Observe and note down your inferences below.

Activity 1

Constructing a Logo

What is shown in Picture 1.3 is a logo constructed in 600X150 pixel size. Let us construct the same logo using Inkscape software. Think about the various tools that could have been used in constructing this logo? Observe and note down your inferences below.

IT @ School

Pic. 1.3

♦ ..............................................................
♦ ..............................................................

Steps

♦ Open Inkscape software and prepare a canvas. For this, click Document Properties in File menu. In the window that opens, use Custom Size
option to make adequate changes. Close the window (You can select canvas of different sizes from Templates in the window).

♦ Use Create Rectangle Tool 🟣 to construct three squares as shown in Picture 1.3.

♦ Select the squares and adjust the size by changing Object Size. This could be done by altering the Height and Width in the Tools Control Bar.

♦ Colour the squares by selecting them and clicking appropriate colours in the colour palette.

♦ Type IT@School inside the square using Text Tool ☐.

♦ Adjust the text size to suit the squares using Select and Transform Object Tool 📡.

♦ Render appropriate colour to the text by selecting colours from the palette.

♦ Save the file in your folder.

♦ Magnify the logo using Zoom in or out tool 🕵️‍♀️.

**Compare the following.**

♦ The logo magnified using Zoom In tool after opening it through GIMP software.

♦ The logo prepared using Inkscape and magnified using Zoom In tool.

Can you note down the differences?

---

Try moving around the logo that you have made in Inkscape. Do you experience any problem? It is not possible to move the objects together; isn’t it? Analyse the note below and examine.

Each shape (line, circles, square etc.) drawn using Inkscape is an object. We can select all the objects in a workspace using Select All (Ctrl+A) in the Edit menu. We can also select the objects in a portion of the workspace. When you click on the Select tool and drag, all the objects within the rectangle that forms get selected. In order to select more than one object, click on each while keeping the Shift key pressed. The part thus selected can be dragged to any slot within the workspace. We can also convert the selected objects into a single unit using Group function in the object menu (ctrl+G). The objects that are ‘grouped’ can be moved around as a single unit.

In order to prepare good pictures in Inkscape, creativity should be supported by sound understanding of various tools and menu options, and their uses. You should be able to use these tools and options effectively. This requires regular practice with a lot of patience. You can develop these skills by practising the activities provided in the subsequent section.
Activity 2

You must be familiar with spheres, cylinders, pyramids etc., from your mathematics lessons. You might have also drawn these objects on paper. While drawing on paper, these objects can be represented only in two dimensions. How do we make these objects look three dimensional? It is through appropriate use of light and shade that we render these pictures a three dimensional effect. Let us see how we can make a sphere using Inkscape.

♦ Draw a circle using Create Circle Tool and colour it

♦ Select Gradient Tool and click on Create Radial Gradient on tools control bar (Picture 1.5)

♦ Double click within the circle. You will get a gradient corresponding to the selected colour

Did you notice the three nodes related to gradient? Try moving the nodes using Edit Path by Node Tool.

What difference do you notice?

Select the square node at the intersection of the two lines and click on the colour palette. Select one of the other nodes and take another colour. Repeat these using different colours. Observe the colours and the nodes at which they have been selected that made the circle appear spherical. Change the positions of light and shade by moving the nodes. Now you can also try constructing other objects in the same method. While constructing a cylinder, try to understand the use of Union in Path menu with the help of your teacher.

Activity 3

You must have studied about amoeba in your biology class. Do you recollect the properties of amoeba? They are single cell organisms without any specific shape. Now let us try drawing an amoeba using Inkscape (Picture 1.6).

Steps

♦ Draw a polygon using Draw Bezier Line Tool.

♦ Manipulate the sides of the polygon appropriately using Edit Path by Node Tool

♦ Click on the Gradient tool to select radial gradient and colour it

♦ Use circle tool to draw the parts of the cell such as nucleus and pseudopodia, and colour them using gradient tool

♦ Use **Object** → **Fill and Stroke** method to give appropriate colour to the cell mass fluid (Pictures 1.7 and 1.8)
How will you mark the parts of a cell? Find out the method and mark the parts.

Try drawing an amoeba by manipulating a circle. Can you figure out a way to make copies of the amoeba that you have drawn? By understanding a few more techniques, you will be able to easily make copies. Use **Edit ➔ Duplicate** to make a copy. Now use selection tool to move that object from the original slot. This was you can copy any number of amoeba by grouping and duplicating objects drawn in Inkscape.

Stack two or more objects one above the other, select anyone of them, and press the following keys – Page Down, Page Up, End, Home. Note

**Fill and Stroke**

See Picture 1.7. The stroke of this object is the back circle. The blue portion is called Fill. In order to see the various options relating to these, open the dialogue box shown in Picture 1.8 by clicking **Object ➔ Fill and Stroke**. Select the object and try out the tabs and options for understanding their uses.
down your observations in Table 1.3.

<table>
<thead>
<tr>
<th>Key</th>
<th>Changes Observed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Down</td>
<td>The selected object moves behind the other object.</td>
</tr>
<tr>
<td>Page Up</td>
<td>.....................................................................</td>
</tr>
<tr>
<td>End</td>
<td>.....................................................................</td>
</tr>
<tr>
<td>Home</td>
<td>.....................................................................</td>
</tr>
</tbody>
</table>

Table 1.3

Usually it is object that has been made the last which appears at the top (Picture 1.9). Sometimes you may have to bring them below other objects. In order to do this, select that particular object and use the option: **Object → Lower**. Instead of this, you can also use Page Down key.

**Activity 4**

You must have noticed arches that are typically part of school gates. See such an arch shown in Picture 1.10. Discuss the tools needed to draw this and note them down.

**Required Tools:**
- The tool to draw circles
- .....................................................................
- .....................................................................

Use Picture 1.10 and the steps listed below to construct a banner for your school in Inkscape.

**Steps**
- Draw a circle
- Convert it into a semi circle using Edit Path Node
- Make two duplicates using **Edit → Duplicate**. Reduce the size of the duplicates and arrange them as shown in Stage 3 of Picture 1.11
- Type in your school’s name using text tool
- Select the semicircle in the middle and the text together. Select **Text → Put on Path** option. Your school’s name gets arranged along the central semicircle. Provide adequate space before the text and do proper spacing.
- Select the central semicircle and remove its stroke colour and fill colour
- Select the other two semicircles together and click on **Path → Difference** option.
Let us now see how to save selected objects in a picture as raster files. First select the required portion of the picture. Take **File → Export Bitmap** option. Click on Selection tab, assign a file name and Export. The selected portion alone gets saved as raster file in .png format (Picture 1.11). Observe the other options in Export Bitmap dialogue box. Try out and understand their uses.

![Picture 1.11](image)

**Activity 5**

What is shown in Picture 1.13 is a flower drawn in Inkscape. In addition to the tools that you have already used, a few additional ones have also been used here. Draw a flower using the steps given in Picture 1.14 and save it in your folder.

![Picture 1.13](image)

![Picture 1.14](image)

- Use the following note to save Picture 1.11 in .png format.

- Draw a line by clicking Pencil tool at the top and bottom

- Select the line, use **Edit → Clone → Create Tiled Clones**. In the dialogue box that opens, select PM:Reflection from Symmetry tab. Provide 1X2 for Row and Column, click Create and close the dialogue box.
Select the line, use Edit → Clone → select original option. Click on the line using Edit Path by Node tool and drag the line to one side. The line bends symmetrically to both sides. Make it into the shape of a petal. Select it fully and use Fill option to colour it.

Now select the petal in full and use Edit → Clone → Unlink Clone option. Select Path → Union. This makes the petal an independent object.

Make duplicates of the petal and arrange them in the shape of a flower using tools such as Rotate and Flip in the Object menu.

Select all the petals together and use Path → Union.

In order to rotate an object in a given angle, open the dialogue box using the option Object → Transform. Use the tools in Rotate tab in the dialogue box. It is possible to arrange the petals by double-clicking on the petals also.

What all need to be done now to develop this into the flower shown in the picture? Use the other techniques that you have learned to complete the picture.

Additional Activity

Inkscape is a software application used in drawing pictures to produce animation. Try making such a picture using this software. In order to animate a picture, we have to draw each of the moving parts separately. You know that the pictures drawn in Inkscape are combinations of objects. You also know how to do grouping of objects. In addition, you know how to select parts of a picture and save them as raster files. Now try drawing the picture of a bird for animation. Save its body, wings, beak, and eyes as separate files. The files thus saved can be used when you learn animation.

Follow up Activities

Construct your school’s logo using Inkscape and save it as a raster file in your folder. Include this logo in the home page of your school’s website.

Draw the different stages of phagocytosis in the safety and health care chapter of your biology text book and save it in your folder.

Refer to the dialogue between Damayanti and the swan in Nalacharitam Attakkatha given in your Malayalam textbook. Prepare the drawings of different body parts of a flying swan and save them as individual files in your folder for later use in animation.
We know the importance of data collection for academic activities. There are various methods for data collection and analysis. You have done data collection and analysis on the health aspects of children in Class IX. In order to make reliable inferences through appropriate analyses, it is necessary to first tabulate the data systematically.

What were the problems that you faced while tabulating the data on the health habits of children in Class IX?

- Size of the table
- ...........................................................
- ...........................................................
- ...........................................................
- ...........................................................

How did you address these problems? What were the techniques that you used?

- Cell freezing
- ...........................................................
- ...........................................................
- ...........................................................
- ...........................................................

Now let us understand some new ways of addressing the problems faced in tabulating data

Data Form for Tabulating data

Let us see how to use Data Form to tabulate data. Let us do this by preparing a table comprising the names of the children in your class, their house names, age, addresses, and parents’ names. In order to do this, type in the required titles in Open Office Spreadsheet and select (Picture 2.1).
Now open the Data Form window by selecting Data → Data Form (Pic. 2.2).

See the boxes that appear in Data Form. Each box corresponds to a title given in the spreadsheet. Type data in all the boxes and click New button. See the changes that occurred in the table. Practise entering data in other tables too using Data Form.

Let us prepare Health Card

It has been decided to collect information on the heights and weights of children as part of total physical efficiency programme. Can we tabulate the data collected and prepare health cards for the children in your class? We can use Data Form for tabulating the data required for health card.

What are the types of information to be included in health card?

See the model questionnaire for data collection.

Prepare a similar questionnaire in Open Office Writer and collect information on all the children in your class.

<table>
<thead>
<tr>
<th>Health Card - Questionnaire for Data Collection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admission No. ......................................</td>
</tr>
<tr>
<td>Name ..................................................</td>
</tr>
<tr>
<td>Class and Division ..................................</td>
</tr>
<tr>
<td>Height ..................................................</td>
</tr>
<tr>
<td>Weight ..................................................</td>
</tr>
<tr>
<td>Age .....................................................</td>
</tr>
</tbody>
</table>

We can include body mass index (BMI) and some analysis based on it to improve the health card. For this, we have to tabulate the available data and analyse it. As a first step, tabulate the data collected using Data Form tool in spreadsheet.

Look Up Function for Classification

From the table that you have prepared, children can be classified based on BMI. Let us have four categories – Those who are underweight, children of normal weight, those who are overweight, and those who are obese. Let us label these categories as ‘Underweight’, ‘Normal weight’, ‘Overweight’, and ‘Obese’. In order to do this classification, calculate BMI for all in the table. BMI is calculated by dividing the weight in kilograms by the square of the height in metres. Children can be classified based on BMI as mentioned above using Lookup function in
spreadsheet. For this, you have to prepare a Lookup chart in the table that you have made. See the model given below (Picture 2.3).

For classifying children using Lookup chart, select the Lookup chart, and use define Range from Data menu. Assign a name and save it.
**Database**

An organised collection of various information on a subject is called a database. Once a large database is prepared, finding specific information from it is difficult. However, information in a computer database can be easily found using software. Computer databases store data in digital form. Such databases can be considered as collection of files containing different types of information. Files in a database are usually called tables. A database may have single or multiple tables. While a database is the collection of various files, different types of information is stored in different tables. For example, if the information on the students and teachers in a school are part of a database, information on students and teachers would be typically stored in different tables.

Unlike other file types, database files do not allow direct access for communication. We communicate with them through database management systems or application programmes. And for the same reason, files in databases are more secured.

Select the cell containing data on the first student (the shaded cell) and click on Function from Insert menu. From the list that appears, select Lookup. The subsequent windows (Picture 2.4) will ask for three parameters – Search Criterion, Search Vector, Result Vector. What do these indicate?

**Search Criterion:** What is the data based on which the student has to be categorised?

**Search Vector:** The name assigned while defining Data Range.

Add the relevant information and click OK to get information on the first student in the corresponding cell. How can we get similar information in the cells below?

**Individual Data from Table**

The table that you have just made can be considered a database. How can we prepare individual report of each student (Health card for example) from this database? Copying the individual data for each student and preparing reports is laborious. We can make this easier by arranging the data relating to each student appropriately. Mail Merge is a technique that helps us do this.

Once the database for preparing health card has been completed, make a template for health card using Open Office Writer. A model is given on Page 21.

Now we have to include relevant information from the database that you have prepared into the template file. For this, select Mail Merge Wizard from Tools menu. In the window that opens, click on Insert Address Block. Select Address and click on Add button. This inserts the table into the document. If tick marks are seen in the window, de-select them, and click Create Salutation. In the window that opens, de-select tick marks and select Edit Document option. Then you can press Edit Document button and return to the main document. Now click Data Source in Edit menu (Picture 2.5); the inserted
You can click and drag the titles in the table to place them appropriately in the document. Click on the window to return to Mail Merge Wizard; select Save Merge Document in the new window and save. Examine the pages in the new file. Now you can print the health card.

What are the other reports that could be prepared from this database?

♦ Identity Card
♦ Conduct Certificate

What are the other reports that could be prepared from this database?

♦ Identity Card
♦ Conduct Certificate
♦ .............................................................
♦ .............................................................

Table appears at the top of the document (Picture 2.6).

What are the other reports that could be prepared from this database?

♦ Identity Card
♦ Conduct Certificate
♦ .............................................................
♦ .............................................................

What are the other reports that could be prepared from this database?

♦ Identity Card
♦ Conduct Certificate
♦ .............................................................
♦ .............................................................
practise by making similar reports.

A new Method for Classification

The training camp for selection to the school volley ball team is about to begin. It is those with more than 160 cm height who will be included in the camp. Class teachers have to issue certificates to the children shortlisted for admission into the camp.

How can you prepare a list of eligible students using the database that you already have? You can do that by categorising students who have more than 160 cm height and those who do not. An easy way is to mark ‘Selected’ in the column next to the one with the data on height for children with more than 160 cm height. Others can be marked ‘Not Selected’. Once this is done, Mail Merge tool can be used to generate the certificate. But how do we mark these? A simple way is to use conditional statements. We can use ‘If’ function for this. Click on the cell in which we have to mark the status of selection and select ‘If’ function. In the window that opens, mark the condition for height (H>=160) in the Test field and the corresponding result (Selected) in Then_value field. Type ‘Not Selected’ in the Otherwise_value field and click OK. What do you see in the cell? How can you include the details of other children in the rows below? Now prepare certificates for all students using Mail Merge tool in the model given below.

Let us prepare a Database

Databases are pools of information collected and consolidated for specific purposes. You have now familiarised yourselves with some preliminary forms of databases. You have also understood the way the information from a database is used for different purposes. Spreadsheets have several limitations in database preparation. Suppose the same admission number was given wrongly to two students in the earlier database. Spreadsheet saves both the entries as there is no inherent mechanism to check such errors. When we handle large databases in a secured way, we have to consider several aspects like this. We need cross checking mechanisms for that. Avoiding duplicate entries, eliminating the possibility of letters getting typed into cells meant exclusively for numbers etc are examples.

CERTIFICATE

Certified that Master/Kumari. Rajeev. K, Standard 10 A is Selected to participate in the Volley Ball Team Selection Camp 2012. His/Her height is 162 cm.

Place Signature of Class Teacher
Date

Software applications that allow secured handling of databases with mechanisms to pre-empt common errors are called database management systems (DBMS). Open Office Database is such a database management system. Open and see the Open Office Database from the Office menu. What all does the software ask for? Examine each window, provide the required information and construct a new database. Before opening your new database, the software asks you to save it. Why does it do so? Discuss.
Observe the Open Office Database window (Picture 2.7). Find out and tabulate the various functions for which you can use this database application.

- **Tables**: For tabulating data
- **Queries**: For finding out specific information
- **Forms**: ..................................................
- **Reports**: ..................................................

### Tabulation

There are three ways of tabulating data using Open Office Database. Select the first method (Create Table in Design View). We can decide on the titles and the data type to be included under each. For example, admission number is a ‘Numeric’ data while name is ‘Text’.

Let us prepare a database which contains the admission numbers of students, name, class, date of admission, and parents’ names. As a first step, we have to specify the titles needed and define their data types. In order to distinguish across data sets, we have to define a primary key. Data defined as Primary key has to be unique as well as mandatory (In other words, data which is not further repeated in the database, and the fields of which cannot be left empty/null). Decide on the data that you would like to define as primary key, and right-click on its left side. Select the option ‘Primary Key’ (Picture 2.8). Please do not forget to assign a name and save the table.

#### Form for adding information into the Table

A technique called ‘Form’ can be used for adding information to the table. Click ‘Form’ button in the Open Office Database window and select the second option (Use Wizard to Create Form). Proceed further and you will be able to select the table that you have prepared and the specific pieces of data / information that you want to include in ‘Form’. Proceed after selecting a
layout from ‘Arrangement of the main form’. Save the form after selecting a suitable layout and colour for the Form (Picture 2.9).
Now try using this ‘Form’ to tabulate data. After adding data in each of the fields that you have created, you can use ‘Tab’ key to go to the next field. Once you press ‘Tab’ or ‘Enter’ key after adding the data on a student, the information get stored in the table that you have made. Enter data this way and open the table and see. This table can be used for other purposes too using techniques such as Mail Merge. Practise more by creating new databases using Open Office Database.

Follow up Activities

♦ Collect the required data for making identity cards of all your classmates and use Open Office Database to prepare the database. Prepare identity cards using Mail Merge technique and print them.

♦ Collect data on household water sources in a ward. Tabulate the data using Open Office Database and prepare a Form for data input.
How beautifully S.K. Pottakkad depicts the changes in the natural surroundings even as Athiranippadam developed into a habituated area! Don’t you see similar changes in and around your place as well? Is it possible to mark the geographic and manmade changes in your area in a map? What kind of a map can we use for it? In order to decide on this, let us take a look at different types of maps.

Wall Maps

Observe any wall map that you are familiar with and find out the details available in it (Picture 3.1).

- Roads
- Railway
- ............................................................
- ............................................................

‘It was through the slow drying up of a large swamp that Athiranippadam evolved into a habituated area. In ancient time, a small river used to flow through it and drain out into the sea a mile towards the western end. As centuries passed by the river dried up, silted, and transformed into a large canal. Even now that area is called Riverside. Slowly the canal too dried up and changed into a swamp. When eventually the swamp started drying up, people entered the fields. Signs of hard work became apparent on the fields. Sugarcane farms, fields where pulses grew, and residential plots came up there.’

‘Oru Desathinte Kadha
S.K. Pottakkad
Satellite Maps

Visit the website www.wikimapia.org and identify your locality. What additional information is available in these maps in comparison with a wall map?

♦ Houses
♦ Panchayat Roads

♦ Pond
♦ ............................................................
♦ ............................................................

We can mark the names of places, roads, institutions, places of worship etc., in wikimapia. Locate your school in the map.

Pic. 3.1

Pic. 3.2 Satellite View
How do we mark the name of our school in wikimapia?

**My School Too in Wikimapia**

After opening wikimapia you can locate your school either through search or mouse scroll. We can see the map in two views – Satellite view and Map view. Once you have located the school, select ‘Add Place’ from ‘Edit Map’ menu from the tools available atop within the map window.
You can mark your school by creating nodes by mouse clicks on the map. Similarly mark your own house also in the map.

Click ‘Save’ button. Provide the information asked for in the window which opens and save the changes.

**QGIS Map**

Now visit the web site keralaresourcemap.in and see the webQGIS map of Akathethara Grama Panchayat in Malamuzha Block of Palakkad District. See the legends provided on the left side of the map on the geographic information of the Grama Panchayat available in the map. What are the themes that are available in the map? We can see any of the available themes in the map by clicking in the check box given on the left side of the corresponding legend. Find out the attributes available in different categories by activating the corresponding legends and clicking on the map.

We have already examined three types of maps. Among these, QGIS maps have the most information available on natural and manmade features. Information provided in QGIS maps can

Pic. 3.6
be used for local level planning and analyses.

Please take note of the description of the uses of such maps in the second chapter of the Social Science II text book of Class X. Now let us understand about QGIS maps and their uses.

Suppose you have prepared an ordinary wall map which captures most of the important features of your place. It would take a lot of effort to analyse the information in the map and use it for any purpose.

On the other hand, suppose we construct a map by preparing individual layers of spatial themes. And suppose we have the facility to analyse the information by overlaying these layers as well as separating them as per our requirement. Then extracting information and analysing them using such maps would be easy. It would also add to the precision of our analysis. QuantumGIS or QGIS is an important software application that helps us construct maps by arranging spatial themes in different layers.

See the ward map given in Picture 3.7. See the main road shown in it. Suppose it has been decided to increase the road’s width by 10 m. Can we find out which all buildings will be affected by such a development? This is possible in a QGIS map as the software has a feature that facilitates this. The

Pic. 3.7
technique used for this is called ‘Buffering’. Let us see how buffering is done.

**Buffering**

In order to do this, we need the digital form of the QGIS map shown in Picture 3.7 (QGIS Project). We can open the map in the geographic information system software Quantum GIS. After opening QGIS, use ‘Open Project’ command in ‘File’ menu to open QGIS Project in your software. Observe the legend box on the left side and note the layers visible in the map. Activate the layers shown in legend box by clicking in the check boxes.

We can find out the buildings that will be affected by a ten metre widening of the main road in the following way.

- First select the layer ‘Road’.
- Use ‘select single feature button’ to select the main road button in the map.
- Click in the following order: Vector → Geo processing Tool → Buffer(s).
- Select ‘Roads’ as ‘Input Vector Layer’
- Provide 10m as ‘Buffer Distance’ for Main Road
- Click the ‘Browse’ button in ‘Output Shapefile’, assign an appropriate file name for the layer, and save it. Also allow for adding new layers.
- In the layer box, drag ‘Road Layer’ to place it above ‘buffer_roads’ layer. Similarly, drag and place
Geo-referencing

Geo-referencing is the process of establishing relationship between the planar coordinates of a map and real world coordinates (latitudes and longitudes). Once we scan a map and bring in the image into QGIS, we need to geo-reference it. The first step in doing this is to identify major landmarks in the area shown in the map. We can find out the latitudes and longitudes of these landmarks by means of Global Positioning System (GPS). The map is then scaled up based on these. Once geo-referenced, we can identify every point in a map with respect to the actual locations.

‘House Layer’ above ‘Road Layer’.

Now can you observe the map and identify the buildings that are likely to be affected by the proposed road widening?

We can ‘Zoom in’ to see more details. For finding the buildings that are likely to be affected, click on the Houses layer. Click on the ‘Identify Features’ tool and click on the points indicating each of the houses. See what all information have been included on the houses while constructing the map.

Adding a New Layer

Did you notice that all the houses are marked on the same layer of the map? There are usually open wells near the houses. However, wells have not been marked here. How can we mark them?

- Click in the following order from QGIS menu Layer → New → New Shapefile Layer.
- In the dialogue box that appears,
### Table 3.1

<table>
<thead>
<tr>
<th>Layer</th>
<th>(Layer Type)</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundaries</td>
<td>Polygon</td>
<td>Name of Grama Panchayat/Ward/Population, Number of houses etc.</td>
</tr>
<tr>
<td>Ponds</td>
<td>Polygon etc.</td>
<td>Ownership, Water availability, Use</td>
</tr>
<tr>
<td>Household Land</td>
<td>Polygon</td>
<td>Survey Number, Land Use, Soil Type, Ownership</td>
</tr>
<tr>
<td>Rivers</td>
<td>Lines</td>
<td>Name, Width, Water availability etc.</td>
</tr>
<tr>
<td>Streams</td>
<td>Lines</td>
<td>Name, Width, Water availability etc.</td>
</tr>
<tr>
<td>Paths</td>
<td>Lines</td>
<td>Name, Type (Main Road or Panchayat Road), Width, Surface type etc.</td>
</tr>
<tr>
<td>House</td>
<td>Point</td>
<td>House Number, House Name, Number of inhabitants, roof (RCC or tiled or thatched)</td>
</tr>
<tr>
<td>Well</td>
<td>Point</td>
<td>Ownership, Water availability, use, state, depth, water quality etc.</td>
</tr>
<tr>
<td>Public Building</td>
<td>Point</td>
<td>Name, type, building number etc.</td>
</tr>
</tbody>
</table>
mark the Layer Type (From the given table).
♦ In the Name box below New attribute, provide appropriate Attributes.

What are the Attributes that can be used? Find out from the table. In the type box below Attributes, you may add additional attributes as well. While using alphabets (letters), you may specify ‘text data’. Similarly for numbers, you may specify ‘Whole Number’ or ‘Decimal Number’. After giving every Attribute, do not forget to click on the tab ‘Add to attributes list’. After entering all the required information, do not forget to assign the file name ‘well’ and save using ‘OK’ button. See the new layer titled ‘well’ appearing on the left hand side. Right-click on the layer, open ‘properties’ and see. Find out the extent to which you can modify this layer (Picture 3.11).

We have to now mark wells on this layer. Use the following steps to mark wells one by one.
♦ Select ‘Well’ layer from the layer box.
♦ Click on the ‘Toggle Editing’ button in the tool bar.
♦ Press the nearby ‘Capture Point’ button which gets activated with the above step.
♦ Click on the spot where you need to mark the well adjacent to the house.
♦ In the Attributes window that opens (Picture 3.12), provide required information and click ‘OK’.

You may now use the same method to create adequate layers to include household land, ponds, rivers etc., in the map.

Let us make our Maps attractive

In the maps that we prepare, let us see how to mark title, scale, direction
In order to do this, click ‘add new map’ tool in the composer window that appears when you select ‘New Print Composer’ tool in the ‘File’ menu. Now click and drag in a slanting direction in the canvas below. The map appears. Use appropriate tools to adjust the map size the way you want it to be (Picture 3.13). Find out what other changes can be made on the map using ‘general’ and

**Attributes**

Options are available to enrich the basic information provided in maps through provision of additional attributes. For example, additional attributes such as survey number, area, soil type, water availability, land use etc., can be added to the attributes of farmland. It is also possible to select these attributes using ‘Identify features’ option in the ‘View’ menu. All the information that we have input would also be available in tabulated form from ‘Open Attribute Table’ in the ‘File’ menu.

**Using GIS geographic information system**

Suppose we want to consider using fallow land to promote paddy cultivation. We can analyse the situation by overlaying soil type, contours, and water sources on the layer showing cultivable fallow land.

Similarly by laying paddy layer over roads layer, we can estimate the area of paddy fields that would be affected by the construction of new roads. Thus, use of GIS maps has become essential in local level planning today.
‘item’ in the ‘properties box’ on the right hand side.

For assigning title, click on the canvas after selecting the ‘add new label’ tool in the composer window. A text box with the label Quantum GIS appears. By making changes in the label box on the right hand side and providing appropriate name, the title can be displayed in the text box.

For adding legend, click on the canvas after selecting ‘Add new vect legend’.

Now click on the canvas after selecting ‘add image’ in the tool bar. Mark ‘North Line’ symbol from the ‘Picture Option’ that appears on the right hand side. Familiarise with other similar tools in the compose window.

Open ‘File’ → ‘Export as Image’ and save the map in the appropriate format.

**Follow up Activities**

- Prepare a QGIS map showing your house and adjacent areas in the map of the Grama Panchayat.

- In the map of the school ward prepared in QGIS, find out the number of wells within 50m radius of the school using frequency analysis.

- Construct India’s different agro-climatic zones in different colours.

- Use GIS software to construct the areas cultivating wheat in the chapter ‘India – Economic Geography’ (Page 87).
We have already learned how to construct geometrical shapes using the computer language called Python. We have also used Python to build ‘countdown clock’ and solve simple algebraic operations.

<table>
<thead>
<tr>
<th>Command</th>
<th>Example</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>import</td>
<td>from turtle import*</td>
<td>For including all the turtle graphics in the program</td>
</tr>
<tr>
<td>raw_input</td>
<td>a=raw_input(“Enter your Name:”)</td>
<td>For assigning a name for the variable ‘a’ through keyboard</td>
</tr>
<tr>
<td>if</td>
<td>if(n&gt;10):</td>
<td>For printing the value of variable ‘n’ as ‘Greater than TEN’ or ‘Less than TEN’ as the case may be</td>
</tr>
<tr>
<td></td>
<td>print “Greater than TEN”</td>
<td></td>
</tr>
<tr>
<td></td>
<td>else:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>print “Less than or equal to TEN”</td>
<td></td>
</tr>
<tr>
<td>range</td>
<td>i=range(5)</td>
<td>In order to assign integers 0,1,2,3,4 for the variable ‘i’</td>
</tr>
<tr>
<td>for</td>
<td>for i in range(11):</td>
<td>For printing the numbers assigned to the variable ‘i’</td>
</tr>
<tr>
<td></td>
<td>print i</td>
<td></td>
</tr>
<tr>
<td>import</td>
<td>import time</td>
<td>For including time module in the program</td>
</tr>
<tr>
<td>write()</td>
<td>write(s)</td>
<td>For printing the value assigned to the variable ‘s’ in turtle graphics window</td>
</tr>
</tbody>
</table>

Table 4.1: Some of the Python commands we have familiarised so far
Some of the Python commands and their uses that we have picked up in classes VIII and IX are shown in Tables below.

<table>
<thead>
<tr>
<th>Python Command</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>a=range(1,10)</td>
<td>In order to assign numbers 1 to 10 in variable ‘a’</td>
</tr>
<tr>
<td>i=i+1</td>
<td>For adding 1 to the number already assigned to the variable ‘i’</td>
</tr>
<tr>
<td>for</td>
<td>The Python command to repeat the operation of certain commands a specific number of times</td>
</tr>
<tr>
<td>a=range(2,21,2)</td>
<td></td>
</tr>
<tr>
<td>a=range(3,31,3)</td>
<td></td>
</tr>
<tr>
<td>for i in range(5,51,5): print i</td>
<td></td>
</tr>
<tr>
<td>clear()</td>
<td></td>
</tr>
<tr>
<td>circle(100)</td>
<td></td>
</tr>
<tr>
<td>a=range(10,1,-2)</td>
<td></td>
</tr>
<tr>
<td>write(s, font=(&quot;Arial&quot;,30))</td>
<td>For printing the value of the variable ‘s’ in the turtle graphics window in different styles</td>
</tr>
</tbody>
</table>

Table 4.2

Now let us understand more about Python language.

‘While’ in Place of ‘For’

We know ‘For’ is the command for executing iterative operations. In computer languages such as Python, ‘while’ command is also used for the same purpose as ‘for’ command. An example of the same program written using ‘for’ and ‘while’ commands is given below. Run both the programs and see. You can open ‘IDLE’ from Programming menu and run it by typing in the programme.

Once you have run the program, find out the following.

<table>
<thead>
<tr>
<th>Program 1</th>
<th>Program 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>from turtle import*</td>
<td>from turtle import*</td>
</tr>
<tr>
<td>clear()</td>
<td>clear()</td>
</tr>
<tr>
<td>for i in range(8):</td>
<td>i=0</td>
</tr>
<tr>
<td>rt(45)</td>
<td>while(i&lt;8):</td>
</tr>
<tr>
<td>circle(50)</td>
<td>rt(45)</td>
</tr>
<tr>
<td></td>
<td>circle(50)</td>
</tr>
<tr>
<td></td>
<td>i=i+1</td>
</tr>
</tbody>
</table>

Table 4.3
Name the iterative command along which we use ‘range’ function.

What would have been the result if we had not used the command ‘i=i+1’ in the second program?

What was the purpose of the command ‘i=0’ in the second program?

Functions in Python

You are familiar with the functions such as SUM, AVERAGE, and COUNT used in software such as Calc and Writer. Similarly, it is possible to formulate functions in Python language too which can be used for simplifying mathematical operations and executing iterative steps. Functions thus

The ‘for’ command within a ‘for’ command

We have learned in previous classes to arrange the commands for a specific number of iterations within a ‘for’ command. Similarly, we can use a new ‘for’ command within the span of another ‘for’ command. In other words, we can use ‘for’ commands within a ‘for’ command.

The activity that you did in the section ‘Computer Kalamezhuthu’ (Computer Floor Art) is given below in two different ways. Comparing the highlighted lines in the programmes, you can appreciate the method in which ‘for’ command is used within another ‘for’ command. Observe Method 2. In this, the command for j in range (30,91,10): is used within the command for i in range(8):

<table>
<thead>
<tr>
<th>Commands</th>
<th>Number of Iterations</th>
</tr>
</thead>
<tbody>
<tr>
<td>from turtle import*</td>
<td>1</td>
</tr>
<tr>
<td>clear()</td>
<td>1</td>
</tr>
<tr>
<td>for i in range(8):</td>
<td></td>
</tr>
<tr>
<td>rt(45)</td>
<td></td>
</tr>
<tr>
<td>circle(30)</td>
<td></td>
</tr>
<tr>
<td>circle(40)</td>
<td></td>
</tr>
<tr>
<td>circle(50)</td>
<td></td>
</tr>
<tr>
<td>circle(60)</td>
<td></td>
</tr>
<tr>
<td>circle(70)</td>
<td></td>
</tr>
<tr>
<td>circle(80)</td>
<td></td>
</tr>
<tr>
<td>circle(90)</td>
<td></td>
</tr>
<tr>
<td>for j in range(30,91,10):</td>
<td>56</td>
</tr>
</tbody>
</table>

Table 4.4

The following table shows the iterations that each command undergoes in Method 2

The ‘for’ command within a ‘for’ command

We have learned in previous classes to arrange the commands for a specific number of iterations within a ‘for’ command. Similarly, we can use a new ‘for’ command within the span of another ‘for’ command. In other words, we can use ‘for’ commands within a ‘for’ command.

The activity that you did in the section ‘Computer Kalamezhuthu’ (Computer Floor Art) is given below in two different ways. Comparing the highlighted lines in the programmes, you can appreciate the method in which ‘for’ command is used within another ‘for’ command. Observe Method 2. In this, the command for j in range (30,91,10): is used within the command for i in range(8):

<table>
<thead>
<tr>
<th>Commands</th>
<th>Number of Iterations</th>
</tr>
</thead>
<tbody>
<tr>
<td>from turtle import*</td>
<td>1</td>
</tr>
<tr>
<td>clear()</td>
<td>1</td>
</tr>
<tr>
<td>for i in range(8):</td>
<td></td>
</tr>
<tr>
<td>rt(45)</td>
<td></td>
</tr>
<tr>
<td>circle(30)</td>
<td></td>
</tr>
<tr>
<td>circle(40)</td>
<td></td>
</tr>
<tr>
<td>circle(50)</td>
<td></td>
</tr>
<tr>
<td>circle(60)</td>
<td></td>
</tr>
<tr>
<td>circle(70)</td>
<td></td>
</tr>
<tr>
<td>circle(80)</td>
<td></td>
</tr>
<tr>
<td>circle(90)</td>
<td></td>
</tr>
<tr>
<td>for j in range(30,91,10):</td>
<td>56</td>
</tr>
</tbody>
</table>

Table 4.5
formulated can be used in other programmes as well.

The following is a program to find the sum of two numbers (Program 3).

<table>
<thead>
<tr>
<th>Program 3</th>
</tr>
</thead>
</table>
| def sum(a,b):
  c=a+b
  return c |

The function of each of the lines in the above program is provided below

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>def sum(a,b):</td>
<td>The command to formulate a function called ‘sum’ for two variables</td>
</tr>
<tr>
<td>c=a+b</td>
<td>For adding the values assigned to two variables and for storing it as a third variable ‘c’</td>
</tr>
<tr>
<td>return c</td>
<td>For returning the sum of the values assigned to the variables to the program that used this function</td>
</tr>
</tbody>
</table>

Method to include Python functions in new Programs

Type down the function in Program 3 and save it in your folder assigning the file name myfunction.py. Then prepare the program given below (Program 4) in the same folder and run it. Alternatively you may run the commands in this programme in Python shell.

<table>
<thead>
<tr>
<th>Program 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>import myfunction</td>
</tr>
<tr>
<td>print myfunction.sum(3,4)</td>
</tr>
<tr>
<td>print myfunction.sum(‘3’,’4’)</td>
</tr>
<tr>
<td>print myfunction.sum(30,40)</td>
</tr>
<tr>
<td>print myfunction.sum(‘a’,’b’)</td>
</tr>
</tbody>
</table>

Activity

Observe the output of Program 4 and complete Table 4.4. Then add a function to find the product of two numbers to the program myfunction.py.

Strings

Strings are data expressed in alphabets. Numbers given within quotes are also considered strings. In Program 4, if you type in a command ‘print myfunction.sum(“Good”,”Morning”), and run it, the computer will print ‘Good Morning’ also as output. This happens because Python did recognise

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>import myfunction</td>
<td></td>
</tr>
<tr>
<td>print myfunction.sum(3,4)</td>
<td></td>
</tr>
<tr>
<td>print myfunction.sum(30,40)</td>
<td></td>
</tr>
<tr>
<td>print myfunction.sum(‘a’,’b’)</td>
<td></td>
</tr>
</tbody>
</table>
that what was given as input data were not numbers. In Python, the symbol ‘+’ is used not only for adding two numbers but for joining two strings as well.

Activity: String Pyramid

Program 5 provides the steps to form a string pyramid. Type it down and run it.

```
The same program prepared using ‘while’ is given in Program 6. Run the program and correct errors if any.

Python Modules

Remember we had included the command ‘from turtle import*’ at the beginning in graphic programs. You might also have noticed that the command ‘import time’ was given at the beginning of programs that include commands concerning time. These commands are used to include Python modules such as ‘time’ and ‘turtle’ in programs. For instance, when ‘time’ module is included in a program using the command ‘import time’, all the functions related to time included in this module will be available in the program. We can also use ‘import’ command to include programs that we have already made in another new program.

When we install Python in our system, several modules that have already been prepared will be available with it. Such modules can be easily ‘imported’ to any program. However, we can import a Python file to another Python file, both should be stored in the same folder.

The Algebra within Strings

Strings are stored in a particular way. Note the few string commands and their functions given below.

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>a=&quot;Good&quot;</td>
<td>For storing ‘Good’ in variable ‘a’</td>
</tr>
<tr>
<td>print a</td>
<td>For printing the contents of ‘a’</td>
</tr>
<tr>
<td>print a[0]</td>
<td>For printing the first letter of the string stored in ‘a’</td>
</tr>
<tr>
<td>print a*3</td>
<td></td>
</tr>
<tr>
<td>print a[:2]</td>
<td></td>
</tr>
<tr>
<td>print a[2:]</td>
<td></td>
</tr>
<tr>
<td>print a[-1]</td>
<td></td>
</tr>
<tr>
<td>print a.upper()</td>
<td></td>
</tr>
<tr>
<td>print a.lower()</td>
<td></td>
</tr>
</tbody>
</table>

Table 4.8
Python Code Generator

wxGlade is a software that helps in writing Python programs in WYSIWYG (What You See Is What You Get) method. This software is included in the Programming menu. When you open the software, the Properties window (Picture 4.2) and wxGlade:Tree window (Picture 4.3) open along with the main window with the tool box (Picture 4.1).

```
Program 6
s=raw_input("Enter Your Name:")
n=len(s)
i=1
while(i<n):
    print s[:i]
i=i+1
```

Python Programming Using wxGlade

Picture 4.4 shows the window that appeared while running a Python program. This Python program was written with the help of wxglade software.

For constructing a window as shown in Picture 4.4, you need to understand frame construction using wxglade, including labels and buttons etc. These are explained below.

**Constructing Frames using wxGlade**

- Open wxGlade software from Programming menu. Three windows open in a row. They are:
Visual Programs

Programming becomes easy when we use visual programs. Visual programs are WYSIWYG models for computer programming. In ordinary programming languages for instance, we have to type in the commands for drawing a square. However in visual programming, we can use drag and drop options the way we use in software such as Writer.

Most of the important programming languages have visual versions. Visual C++ is the visual form of the programming language C++. With wxGlade software given in the programming menu of Linux, programs in programming languages such as Python, C++, Perl, XRC, and Lisp in WYSIWYG model can be prepared.

 nombreux observe the changes in the wxGlade:Tree window (Picture 4.3, Picture 4.7). Name of the new frame and Sizer would have appeared.

Simultaneously observe the changes in the wxGlade:Tree window (Picture 4.3, Picture 4.7). Name of the new frame and Sizer would have appeared.

Click on the Sizer in wxGlade:Tree window. Select the appropriate Sizer from Properties window. Arrange <design>frame window as shown in Picture 4.10.

Including Labels and Buttons

The way to include label and button in the frame is given below.
**Sizer for Arranging Frame**

Sizer is used to arrange rows and columns in frame window. The method of arranging rows and columns using Sizer is provided below.

- Click Sizer in wxGlade:Tree window (Picture 4.7). You will see a corresponding change in the Properties window (Picture 4.8). Click on the button \( \ldots \) against **Class** in the window. From the Select sizer type window that opens (Picture 4.9), select the appropriate Sizer type. If you are constructing a frame with rows and columns similar to the one in Picture 4.4, it is **wxFlexGridSizer** that you have to select.

- Now you can add the required rows and columns by right-clicking on the Sizer in the wxGlade:Tree window.

- Making label: Select ‘Add a static text’ in the main window (Picture 4.1) and click in the first box in the <design> window. The label appears in <design> window as well as wxglade:Tree window. With the help of Widget tab in Properties window, change Label 1 to Number 1. Similarly change the second label also. (See Picture 4.11).

- Adding text box: Click ‘Add a text ctrl’ button in the main window. Following the same steps as those used for making labels, click at the appropriate places to include text boxes as seen in Picture 4.11.

- Adding buttons: Click ‘Add a button’ in the main window to include buttons in the frame. Once you add the first button, two changes are to be made in
Changing the Label and its Contents

While making labels using ‘Add a static Text’ button, the labels that formed are typically named ‘Label_1’, ‘Label_2’. You can change the labels through the following method:

♦ Click on the label that you want to change in wxGlade window. Corresponding changes can be seen in Properties window.

♦ You can also change the label by clicking on the ‘Common tab’ in the Properties window. Option to change the content is available in Widget tab.

Making Python Code

Following are the steps to write Python codes similar to the arrangements in the <design> window in Picture 4.11.

♦ Click ‘Applications’ in wxGlade:Tree window. Then click on the button against the ‘Output path’ option (Picture 4.13) in the ‘Properties’ window to select the required folder and assign a file name. Do not forget the .py extension.

♦ In the same window, select the option ‘Python’, and press the button ‘Generate Code’. Python code would be already made in the recommended folder. Run this...
program by opening ‘IDLE’ or using ‘Terminal’.

**Activating ‘Form’**

It is possible to add numbers in cells while running the program that we have made. But we will not get the sum if we click on ‘Add’ button. A way to address this issue is given below.

♦ Open the Python file that we have created. At the place where the code of sum function appears (Picture 4.14), make changes similar to the changes in Picture 4.15.

♦ Run the programme. The ‘Add’ button gets activated and the result appears on the second button.
Run the program after making changes indicated in Picture 4.16 too. Compare the difference between the two.

The data input into a computer through text boxes are not numeric data. These data has to be converted into numeric data before used for algebraic operations. For this, the function ‘int’ is used in Python.

In Python language, we can use objects such as labels, text boxes and buttons just as we use variables. See the way names of text boxes and functions are included in ‘sum’ function in the program in Picture 4.18. Object names are included in the program as they are in wxGlade:Tree window.

A GUI Software for Me Too

Imagine, if you can open Writer, Calc, GIMP etc., using the software that you have prepared! The Python code required to open some of the programs that you require often is given below.

```python
from Tkinter import *
import os

def callback():
    print "called the callback!"
    quit()
def callback1():
    os.system('oowriter')
def callback2():
```

Activity

- Generate Python code to make a window similar to Picture 4.17 using ‘wxGlade’. Then, update the frame by adding more mathematical operations.
Follow up Activities

♦ Find out the output of the programs given below

Program 1

a = “o”
for i in range (1, 11):
    print i * a

Program 2

a = “o”
c = “  “
for i in range (0, 11):
    print (10-i) * c,(2*i+1)*a

♦ Make adequate changes in the above program to construct the following patterns

(1) ***** (2) ++oooo
    *****    +++000
    ***      ++++0
    **       +++++
    *        +++++

♦ A program to reverse the word PIT into TIP is given below. Rewrite this program into input method

a = “TIP”
n = len (a)
s = “”
for i in range (n):
    s = s+a[n-i-1]
print s

Now make the Python program for opening all the software that you use in Class X.
This is the gist of what famous scientist Gordon Moore said more than forty-five years back about the speed at which Information Technology was growing:

"The number of transistors in an IC chip will double every year; that too without significant additional costs. And this trend will continue at least till 2015."

Gordon E. Moore, Electronic Magazine, April 1965

We are able to use computer and its peripherals with ease. For this reason, don’t you think it will be fun to collect information about the changes happening in the field of computer and its accessories? Let us form groups which will be responsible to gather information about the changes happening in this area. A few tips for this information gathering are given below.

Mouse

Given below is the picture of mouse and various interfaces to connect it to computers.
The Machine Called Computer

Now a days we do not use the serial connector. PS/2 is also fast disappearing. One can see USB mouse and wireless mouse commonly.

The technology used in Mouse has also undergone changes. Look at the bottom side of your mouse. Mechanical mouse worked based on movement of the sphere-like attachment at the bottom. This technology was replaced by the new mouse which works based on the reflection of the light emitted by it. See the speed at which technology becomes obsolete!

---

**Keyboard**

Keyboard is an input device. To connect a Keyboard, the following interfaces are available - PS/2, USB, wireless mode. (What is the usual colour of PS/2 connectors used with keyboards?)

The order in which the different keys are arranged in a keyboard is referred to as keyboard layout. Most of us are familiar with the QWERTY keyboard layout used for English language. This was originally devised for Type writers. The layout of the keys was done with the intention that typing levers should not get entangled while pressing the keys which are adjacent. To overcome this difficulty, the layout was done in a manner such that the alphabets most frequently used in the English are not placed side by side. We know that while using keys in a computer keyboard they do not get entangled. New keyboard layouts enabling one to type faster based on the speciality of the human fingers have been manufactured. **Dvorak, Colemak** are examples of such keyboards. Layout of Dvorak key board is as in picture 5.2 below.

```
<table>
<thead>
<tr>
<th></th>
<th>@</th>
<th>2</th>
<th>#</th>
<th>$</th>
<th>%</th>
<th>^</th>
<th>&amp;</th>
<th>*</th>
<th>(</th>
<th>)</th>
<th>_</th>
<th>+</th>
<th>Delete</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Shift</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Space</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

C-DAC, a body under the Government of India has devised a keyboard layout called Inscript using which it is possible to type 12 Indian languages. Layout of this keyboard is based on the similarity of the alphabets of these languages. Key positions of alphabets are the same for all the languages.

Now a days we do not use the serial connector. PS/2 is also fast disappearing. One can see USB mouse and wireless mouse commonly.

The technology used in Mouse has also undergone changes. Look at the bottom side of your mouse. Mechanical mouse worked based on movement of the sphere-like attachment at the bottom. This technology was replaced by the new mouse which works based on the reflection of the light emitted by it. See the speed at which technology becomes obsolete!

---

**The way ships are brought to shore!**

We refer to the computer we use as System? The reason for this is because we use keyboard, mouse, monitor, and the system unit in an integrated manner. How do we connect all this to the system unit?

Port is the place where ships physically ‘connect’ to the shore. Similarly, we have ‘Ports’ in the system unit which ‘connect’ input and output devices (also storage devices) to the system.
<table>
<thead>
<tr>
<th>Hardware Interface</th>
<th>Which Tool?</th>
</tr>
</thead>
<tbody>
<tr>
<td>P.S.2</td>
<td></td>
</tr>
<tr>
<td>Serial</td>
<td>Serial Modem (Not in Use)</td>
</tr>
<tr>
<td>Parallel</td>
<td>Dotmatrix Printers</td>
</tr>
<tr>
<td>VGA</td>
<td>Projector</td>
</tr>
<tr>
<td>USB</td>
<td>Printer</td>
</tr>
<tr>
<td>RJ45</td>
<td></td>
</tr>
<tr>
<td>TRS Plug (Tip, Ring, Sleeve jack)</td>
<td>Audio Input, Output Ports, Analog Signal Line In</td>
</tr>
</tbody>
</table>

![Image of computing components](Pic. 5.3)
We need ports in the system unit which match the interfaces. Picture 5.3 shows different types of interfaces and various ports which are used to connect them to system. Fill up the blanks in the Picture.

In different types of computers such as laptop, net book, system unit, monitor and keyboard are integrated as a single unit. But do the ports to connect external devices differ? Where are the provisions for these ports? Inspect and find out.

**What is inside the box?**

System unit is a box (system cabinet) containing many parts of the system. What are the units inside the system cabinet? Let us learn in detail about the various parts.

**Microprocessor**

Microprocessor is regarded as the brain of the computer. It is here that the processing of data as per the commands is carried out. This is referred to as central processing unit (CPU). Picture 5.4 shows a microprocessor called Athlon 64 which is manufactured by a company called AMD (Advanced Micro devices).

It is not necessary to open the system unit to know about the CPU. We can use the programme **Sysinfo** (Applications → System Tools → Sysinfo) for this. Observe the details of the Intel dual core microprocessor as shown by the software.

Now examine your system and fill in the details in the table below

<table>
<thead>
<tr>
<th>Manufacturer of the microprocessor</th>
<th>System shown in the Picture</th>
<th>The system that you use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intel</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name of the Model</td>
<td>Pentium Dual-Core</td>
<td></td>
</tr>
<tr>
<td>Clock Rate</td>
<td>1200 MHz</td>
<td></td>
</tr>
<tr>
<td>Cache Memory (L2)</td>
<td>1024 KB</td>
<td></td>
</tr>
</tbody>
</table>

Table 5.1

When we open a system unit, we will not be able to see the processor as in the previously shown pictures. When
computer operates the processor heats up significantly; hence we have a separate cooling system for them. Picture 5.6 shows the heat sink and fan used to cool the micro processors.

Activity 1

Inspect the systems available in the school and tabulate the manufacturer and model of the microprocessor. How many manufacturers are you able to list?

Clock Rate

Think about the extent of information exchange happening between the CPU and other units of the system in a single second. If the information flow is not structured and streamlined, data reception and retrieval will all become chaotic.

How is the working of the system organised?

It is the quartz clock inside the CPU which coordinates the functions relating to information exchange. It is according to the beat of this clock that the different units function. The pulse rate of this clock is called clock speed (Frequency) of the CPU. The unit for this frequency is Hertz, for example Pentium IV 3.2GHz.

Cache of CPU

CPU of a computer works at a very high speed and invariably other units cannot match this speed. Hence there is a delay in information access by the CPU. How is this problem resolved?

This is resolved by using intermediary storage mechanisms within the CPU. The most commonly used data and commands for a given user can be stored there. This mechanism is called CPU Cache. The storage capacity of this is referred to as Cache memory. Refer to Table 5.1

Mother Board- Foster Mother to all Units

We have learned that there are different components which are integrated and called the system. But who integrates all these components?

It is an integrated circuit board called Motherboard which enables this. All components of the system are connected to this board. In the computers of earlier days, there used to be separate Integrated Chips (IC) programmed to carry out different functions. As time moved on, complex chips were manufactured and were called VLSI Chips- Very Large Scale Integrated Chips. Every motherboard has two VLSI chips. One is called the Memory Control Hub (North Bridge, Host Bridge), and other is called the Input/Output Hub (South Bridge). The motherboard is known by the manufacturer of this Chip. Refer to Picture 5.7.
Which chipset does the motherboard of your computer have? Run the Sysinfo programme and inspect the Hardware details. See Picture 5.8. Now fill up Table 5.2. The motherboard with the chipset shown in the table is referred to as Intel 82945 chip set board.

**Activity 2**

Inspect different types of motherboard and identify the Slots and the 2 VLSI chips in Picture 5.7. Find out the manufacturers of such type of VLSI chips. Are the same manufacturers engaged in the trading of Motherboard?

---

**Hard Disk for Information Storage**

See picture 5.9, are you able to recognise the device? Operating system, application software, and the files that we generate - Most of the things in a computer are stored here.

One or more disks connected to a spindle – that is the structure of a hard disk. Disks are coated by a magnetic material. Information is stored in the disk by activating the magnetic property of this material.
There are Heads that enable reading from the disk and writing on it. It is through the motorised rotation of the disk and heads that all areas of the disk are accessed.

### Partition and File Systems

When we buy a new hard disk, it would be empty. In that state we cannot store files generated by different software in it. The reason is that the disk does not have any locations defined for storing files. These are needed for storage and retrieval of files.

We need to divide the disk into blocks or segments to know where a file is stored. These blocks need to be given...
into separate parts. Such parts created are referred to as hard disk partitions.

Sometimes a single operating system may need multiple partitions. In a GNU/Linux operating system following partitions are suitable. (In some cases only root and swap will be present)

- **Root (/)** - To store files related to the Operating System.
- **Home (/home)** - To store files created by the user.
- **Swap** - A high speed file system to store data temporarily.

Pen drives, Memory cards, CD/DVD are all devices to store data. To read and write data from a CD/DVD we use a CD/DVD drive.

### Activity 3

When we purchase a pen drive, there exists a file system in that. In order to install a different type of file system we use the program ‘Disk Utility’ (System → Administration → Disk Utility). Do not forget to un-mount the drive before formatting.

---

**Table 5.3**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>File Systems used</th>
</tr>
</thead>
<tbody>
<tr>
<td>GNU/Linux</td>
<td>Ext3, Ext4</td>
</tr>
<tr>
<td>Microsoft Windows (c)</td>
<td>FAT 32, NTFS</td>
</tr>
<tr>
<td>Apple Macintosh (c)</td>
<td>HPFS, HPFS+</td>
</tr>
</tbody>
</table>
We need to create two partitions with two different file systems - NTFS, Ext3 in a pen drive with 4 GB storage capacity. See picture 5.10.

**Random Access Memory**

We have understood that microprocessors handle data in computers. Microprocessors are high speed devices. Therefore the data to be processed by them and the related commands should be made available at high speed to them. But where is the information that has to be fed to the microprocessor? This may be stored in the hard disk or CD drive; it could also be information fed real time. For processor to handle information, another interfacing device is needed. Such a device is called RAM or Random Access Memory.

- The information needed for the computer to work is first temporarily stored in RAM and then made available to the microprocessor. Even the operating system, which is essential for operating the computer, is first moved to the RAM. This process is what we call booting.

- Even though RAM is a high speed electronic device, it functions only when there is power. All the data in RAM is lost when computer is switched off.

When we do tasks like video editing which require the user to open large multiple files at the same time, the storage capacity of RAM may not be sufficient. In order to overcome this limitation the best way is to create a separate file system in the hard disk itself. The file system thus created in the hard disk is called Swap.

Use the program Sysinfo and fill up the table 5.3. Note that storage capacity of 938 MB shown is what is available to the user after making provisions for different requirements of operating system. (The actual storage capacity of RAM could be much more)

**Add On Cards**

Suppose we want to see TV programmes in the computer. It is not possible with the available features of
We now know that when the system is not running, the programmes related to operating system and others are stored in the hard disk. The process of moving these to RAM is called booting. How will the RAM get the command to understand that these programmes are already present in the hard disk and these have to be moved to RAM? Where is such a programme stored?

This is done by the BIOS programme stored in an IC Chip in the motherboard. What all does the BIOS do?

♦ As soon as the system is switched on, BIOS does a test (Power On Self Test - POST) to ascertain whether all the units are functioning properly. We can see the result of this test. You might have seen the message appearing on your monitor screen similar to what is shown in picture 5.15.

♦ If there is a loose connection in the port where the RAM module is a computer when we buy it. We have to add mechanisms to convert the analog signal (coming through the cable) to digital signal in the motherboard. We use devices similar to the one shown in picture 5.13, which are easily available. These are called Add on Cards. Some types of Add on Cards are listed in Table 5.4.
connected, or if there is a dust coating, BIOS detects those. Find out what the response would be.

♦ BIOS arranges programmes required for running basic hardware like mouse, keyboard.

♦ BIOS boots the system. The operating system for booting may be in the hard disk, in a CD in the CD drive, or in a pen drive. We can give instruction as to wherein the operating system required for booting is stored.

♦ BIOS keeps the system’s clock ticking even when the computer is switched off.

**Activity 4**

Though most of the programmes stored in a BIOS chip are not changeable, we can set up a small part. This is called the CMOS set up. When computer starts operating, we can enter the BIOS setup window by using any of F1, F2, or Del keys (see picture 5.16).
♦ Check the time shown in BIOS; if the
time is wrong set the same.

♦ Set CD drive as the first boot device.
If CD drive is given as the first boot
device, only after checking whether
the drive has CD with the OS that
other components including hard
disk will be checked.

Check if the time shown in the sys-
tem clock is the same as the time shown
in BIOS.

Path of Electricity

What is the power requirement of
an ordinary computer?

It is not easy to answer this ques-
tion. See table below:

<table>
<thead>
<tr>
<th>Device</th>
<th>Operating Voltage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Motor to run the disk in CD drive and hard disk</td>
<td>12V DC</td>
</tr>
<tr>
<td>Different types of digital circuits</td>
<td>5V DC, 3.3V DC</td>
</tr>
<tr>
<td>Microprocessor</td>
<td>1.3 - 1.5V DC</td>
</tr>
</tbody>
</table>

Table 5.6

What are all clear from the table ?

♦ All the devices work on DC -
Direct Current.

But we supply 220V AC to the sys-
tem. This has to be converted into
DC. In addition, the fluctuations in
the line voltage have to be over-
come.

♦ Every component within the
system and outside work at
voltage levels suitable to them.

In addition, all the components do
not work always (for example CD
Drive). And when they work,
power consumption varies ac-

SMPS - Switched Mode Power
Supply

This is the power house of a com-
puter. Based on the discussion above
can you list the various functions of
SMPS?

Direct current of various voltages
emanating from the SMPS reaches the
motherboard through cables of differ-
ent colours. See picture 5.18. You can
see the cables from SMPS and the power connector used to join these to the motherboard.

Can you see such a SMPS in a laptop? Will you find out the alternative mechanism used there?

**Follow Up Activities**

1. “So high is the rate at which hardware techniques become obsolete”! Prepare a note on the transformation that computers have undergone over the years (Early machines, super computers, personal computers, laptops, net books, palmtops and tablets).

2. Suppose we have been instructed to prepare a proposal for buying computers for our school. We know how to find out the specifications of the existing systems in the school. Collect data about different systems and their specifications available today. Of these, what combinations will you recommend to the school? Conduct a seminar on the various suggestions in all divisions of class X.

3. Think about conducting a quiz on hardware in the class. Questions should be introduced as detailed presentations.

4. What is to be done to install GNU/Linux in your system? See notes below.
   - Put the CD/DVD containing the Operating system in the corresponding drive.
   - Set this drive as the first boot device.
   - System gets booted from the CD. Format the hard disk, create partitions and file systems for the operating system.
   - Set Keyboard layout, system, time zone of the country, name of the user and password.
   - ......................................................
   - ......................................................
   - ......................................................
   - ......................................................
Let Us Give Life to Sketches

Depicted above is the excitement that Vinod, a student from Kozhikkode district felt on completing his first animation film. Do you remember you animating a car using GCompris while studying the part ‘Secret of Animations’ in the Class IX textbook of ICT?

What all did you do to animate the car? Play the same game on your computer once again and fill up the following list.

♦ Selected the picture and brought it on to the canvas.
♦ Included the picture in all the frames.
♦ ............................................................
♦ ............................................................

You are beginning to understand the method of animating still pictures using software; aren’t you?

What we animated now is a picture stored in the computer. What if we can animate pictures that we have ourselves drawn? We can do this using animation software. If we are able to reproduce a world of our imaginations in a computer, don’t you think we will experience the same excitement as Vinod? We can use Tupi software available in our operating system for this.

Let us draw Pictures

We know that for producing animation we require several pictures. We can draw these pictures in the animation software itself. Draw a picture in Tupi with the help of directions given below.

♦ Open Tupi : 2D Magic in Graphics menu.
♦ Move in the order File → New →

“The first picture I drew on a computer was that of a butterfly. When its wings started fluttering a little, It did not occur to me that I have animated it...it looked as if I have given life to it...”
New Project, Open the canvas window, assign Project Name and FPS and click OK.

♦ You can select pencil from the tool box and draw on the canvas.

Let us give life to a Butterfly

Haven’t you completed drawing the picture? In order to make the picture move, we need the picture in more than one frame. Find out the frame in which your picture is available from...

Animation

Animation is the process of creating the impression of a motion picture by continuous and speedy exhibition of two or three dimensional pictures. Once we finish watching a picture, its impression remains in our visual field for one-sixteenth of a second. Animation technology is based on this phenomenon called Persistence of Vision. Because of this, when a sequence of pictures showing continuous action appears in front of our eyes, we see them as a motion picture. Thomas Alva Edison was the founder of this technology. Walt Disney, William Hanna, and Joseph Barbera are people who made major contributions to this field. Tupi, KToon, Synfig Studio, Pencil etc., are 2D animation software available in GNU/Linux. Blender is an open source 3D animation software. Big Buck Bunny, Elephant’s Dream, Sintel etc., are important animation films made using Blender.
Suppose we want to exhibit the animation that we are making at the speed of six FPS. At that speed, how many frames will be needed for an animation film of three minutes duration? Discuss with your friends and copy the picture into as many frames as required.

Have you included pictures in all the frames as needed? Now the picture is at the same spot in all the frames. For instance, the positions of the first and eighteenth pictures are the same. Therefore when they move, we will not feel any movement. What did we do to move the car in GCompris? Based on the study notes, prepare an animation film by making adequate changes in the positions of pictures in different frames and try running the animation film.

Did you run the animation that you have made? Do you think you should make any change in it? Discuss based on the steps given below and resolve it. Then make appropriate changes in the animation and again run it. If needed, take your teacher’s help.

Isn’t it necessary for moving pictures to look natural?

Layer 1 in Tupi main window. How do we copy the picture into other frames? Do we have to draw the picture in all the frames?

We know that we can create copies of a picture drawn in a computer using Copy and Paste technique. By copying the frame in Tupi to other frames, we can copy the picture the required number of times. Copy your picture into other frames with the help of the following steps.

♦ For copying frame - Click on the frame from which picture is to be copied, Right Click → Copy frame.

♦ For posting to new frame - Click on the frame to which picture is to be pasted, Right Click → Paste in frame.

For Changing the Picture Position in Each Frame

Select the frame containing the picture from the Layer Box in the Exposure Sheet in Tupi main window. The select Object Selection Tool from the Tool Box and change the position of the picture on the canvas relative to the position of the picture in the first frame. When you select the entire picture using this tool, several selection nodes appear around the picture. This is because each line created using Pencil tool stay separately in the picture. You can move the picture only of all these lines are moved together. We can use Arrow key for this. On the other hand, if the picture stays as a single entity with just four nodes, we can move it using mouse. While moving a picture using mouse, Ctrl and Shift keys can be used to control the speed.

The number of frames exhibited in a second in a motion picture FPS (Frames Per Second). A motion picture of normal speed forms up when 12 - 24 frames move per second. We can arrange the speed of a motion picture by adjusting the number of frames.
Now select the next frame and move the picture a bit ahead compared to the preceding frame. Thus arrange all the pictures one by one according to a path we want the object to take.

We have changed only the position of the picture in all the frames?

Let us understand the Tools

Now that you have drawn a picture and animated it, list out the tools that you have used and complete the table.

To play the Animation

Click the Player menu. Click on the Play button below.

Let us save the File.

Use File → Save Project for saving a Tupi project file.

For drawing a picture in Tupi, two types of canvases are available – Background mode and Frames mode. Pictures to be animated are to be drawn on Frames mode. For a picture to be included in the background, draw it in background mode.
Activity 1: Let us make a Story and Prepare Story Board

Systematic preparatory work is necessary for making animation films. Story board preparation is an important component in that. We have to first convert the story into a Screen Play and then into a Story Board. Details of each scene is to be worked out in the Story Board. Context of the story, still images, moving pictures, the length of each scene, details of dialogues or background sounds if any etc., are to be included in separate boxes and the sketches of each scene should be prepared. Even though it is better to include everything that constitutes a scene in a single box, a single scene can also be drawn as different shots if needed. It is after preparing detailed Story Board like this that you should start the production of an animation film.

Complete the Story Board in Picture 6.3 to 6.4. We shall make an animation film out of this.
We can import pictures drawn using Drawing/ Image Editing software applications that we have already familiarised ourselves with and import the pictures to Tupi. If we thus draw pictures in advance, animation production becomes easier.

Which are the pictures to be drawn for preparing the first scene? Analyse the given study note and complete Table 6.1.

Draw the pictures needed for the other scenes too. For this you may use Inkscape, GIMP, Expaint, Tuxpaint etc., which you are already familiar with.

Insert the background image for first scene into Background mode and insert the other pictures into the first frame of Frames mode. Join the pictures as shown in Picture 6.5 and prepare the picture to be moved in the first frame.

Now insert the above frame into other required frames and make the changes needed for animation in each frame. Play the animation and see.

Now that you have played scene 1, do you think any change is needed in the movement of the character? What was FPS that you had given to this scene? Keep playing again and again.

Have you completed the Story Board? Remember how our last animation film lost natural movements as we moved the pictures together. In the current story board if we have to move the characters in each scene separately, we have to prepare their body parts separately. Should we draw these in Tupi itself? What if we draw the pictures using image editing and drawing software applications that we have already familiarised ourselves with and import the pictures to Tupi? If we thus draw pictures in advance, animation production becomes easier.

We can import pictures drawn using Drawing/ Image Editing software applications into Tupi. Image files with extensions .png, .jpg, .gif, .xpm can be imported using InsertBitmap menu. It is .svg file that can be inserted using Insert SVG File menu into the canvas. When we make drawings in other applications for inserting into Tupi, background images should be drawn at the size of Tupi canvas (width=520, height =380) where as other pictures such as characters should be drawn in relatively smaller sizes. When body parts are drawn separately using GIMP, you should delete the background layer and save the picture in .png format.
Let Us Give life to Sketches

by changing FPS each time. Find out the most appropriate FPS and save. Don’t we have to take care of this aspect in each scene? Discuss with your friends and prepare for the other scenes.

Table 6.1

| ♦ Background | - | Size 520x380 |
| ✦ ............... | - | ............... |
| ✦ ............... | - | ............... |
| ✦ ............... | - | ............... |

Table 6.2

<table>
<thead>
<tr>
<th>Scene 1</th>
<th>Scene 2</th>
<th>Scene 3</th>
<th>Scene 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>FPS</td>
<td>6</td>
<td>..........</td>
<td>..........</td>
</tr>
<tr>
<td>Scene duration</td>
<td>3 Seconds</td>
<td>..........</td>
<td>..........</td>
</tr>
<tr>
<td>Number of frames</td>
<td>18</td>
<td>..........</td>
<td>..........</td>
</tr>
</tbody>
</table>
We can enlarge Images

While making animation, in order to achieve natural movement of characters, we have to move the picture into different places in a frame. For this, select the inserted picture using Object Selection tool. Then if you click on the white mark in the middle, you will be able to move the picture around. You can also rotate the picture by moving the selection node that appears when you double-click on the same mark. You can change the picture size by dragging the selection nodes on the sides.

Activity 2: Exporting the File

You have now completed the first scene. Now we are able to play animation only in Tupi software. Can we run this file in other applications? Remember we had studied in previous classes that it is necessary to export these files into appropriate formats for playing them on Media Players. Export the file into .avi format using the steps in the given note. You may play the exported file in an appropriate Media Player.

Once you are through with the first scene, open new project file, prepare other scenes also, export into .avi format and save in a folder.

File Export

In order to save a file from Tupi as video, we have to export the file. For exporting, click File → Export Project. In the windows that open, select the video file format and the scene to be exported and click ‘Next’. Then assign the folder name and file name, specify FPS, and click ‘Save’.
**Onion Skinning**

It is a technique used in animation films. It is a method of showing multiple frames of the same picture on the canvas. Seeing the preceding and succeeding frames on the same canvas gives us idea on the changes that are required in each frame. We can arrange the display of preceding and succeeding frames by changing numbers in the Onion Skin box in the Tupi Main Window.

**Activity 3: Joining the Scenes**

Scenes are now ready; aren’t they? You know that there are more steps involved in completing the film as per the Story Board. Which are the software applications that we can use for these steps that you have familiarised yourselves with in Class IX?

With the help of chapters 7 and 9 of the ICT Textbook of Class IX, join all these scenes into a single video file and export (Picture 6.9).

<table>
<thead>
<tr>
<th>♦ Join the scenes</th>
<th>Openshot Video Editor</th>
</tr>
</thead>
<tbody>
<tr>
<td>♦ Voice recording</td>
<td>..........................................................</td>
</tr>
<tr>
<td>♦ ..................................................</td>
<td>..........................................................</td>
</tr>
<tr>
<td>♦ ..................................................</td>
<td>..........................................................</td>
</tr>
</tbody>
</table>
Even though Tupi allows preparation of more than one scene using Scene Manager, the current version (Version 1.0) does not have the functions to add sound and titles of our choice. For stages since joining of scenes, you may use either Openshot video editor that you have familiarised yourselves with in Class IX or other video editing applications available in GNU/Linux.

**Another Way of Creating Motion**

We moved pictures by changing their position in each frame. You can also create the feel of moving pictures by moving the background in each frame while keeping the character/object stationary. Objects with stable trajectories such as aeroplanes can be expressed in this method. For this, we have to either prepare the background in double the width of the canvas or enhance the width by dragging. Insert a background picture thus prepared into Frames mode and keep it on one side of the canvas.

Or, in other words, move the background in the same direction in which the character has to move. Remember, when you move the background this way, it should fill the canvas. Then insert the aeroplane to be moved into the first frame.

Now prepare the required number of frames by copying the first frame into all other frames. Once all the frames are ready, select the background image alone in each frame and move it in the opposite direction of the expected trajectory of the aeroplane at exact distances. It is better to use Arrow key for moving the background image.

Now play the animation using Player menu...

**Follow Up Activities**

- Remember the dialogue between Damayanti and the Swan (Hamsam) depicted in Nalacharitam Attakkatha in Malayalam textbook. Use Tupi to prepare an animation of the swan flying down.
♦ In the chapter ‘Protection and health care’ in Biology textbook, the process of Phagocytosis is explained. Observe it and prepare an animation film on the process. Display it in your class.

♦ Analyse the chapter on Light Phenomena in Physics textbook and visualise dispersion of light using Tupi software.

♦ Prepare a simple animation film for awareness building on a programme being organised in school as part of anti-intoxicants day.
You understood some basic concepts of computer networks by studying the chapter titled ‘Knowledge on your fingertips’ in Class VIII.

You were able to open the pictures prepared on a computer in another computer and make changes in the pictures. This was possible because computers could be connected together through networks. This chapter discusses how these networks can be made use of in computers that work on our operating system.

Remember what you have learned in previous classes. What are the advantages of linking the computers in your school lab through a Local Area Network (LAN)?

♦ Computers connected through the network can exchange information.

♦ Equipment such as printer connected to a computer can be used by other computers in the network.

In order to exchange information between them, computers have to recognise one another. How is this possible? Let us examine.
**Address of a Computer**

Every system in a network is given an address so as to recognise one another. This address is called IP Address. Do you know the importance and peculiarities of IP address? Find explanation to this question from the subsequent sections.

Let us now see how to figure out the IP address of the computers in the school lab.

**Finding the IP Address of Computers**

**Activity 1**

Switch on the computers in the lab. Also switch on network equipment such as hub and modem.

Right-click on the icon of the network monitor applet (NM-Applet) in the panel and click on Connection Information. (Picture 7.2).

![Pic. 7.2](image)

See the window that opens. You can see the IP address of the system (Picture 7.3).

![Pic. 7.3](image)

**TCP/IP**

All the systems that exchange information over a network need not be of the same type. They may be different in hardware configuration and operating systems. Therefore there are some common laws that control information exchange between systems. These are called network protocols. TCP/IP (Transfer Control Protocol/Internet Protocol) is a protocol for exchanging information over networks. In this protocol, every system needs to have a unique IP address. There are two methods used in assigning IP address – IP Version 4 (IPv4) and IP Version 6 (IPv6). The most commonly used protocol over Internet is still the first version – IPv4.

Using the above method, find out the IP addresses of all the systems in the lab and fill up the second column in Table 7.1. Now shut down all the systems. Now switch them on in a different order, repeat the earlier exercise and fill up the third column with the results.
**Structure of IP Address**

IP Address is given in a format with four numbers separated by dots such as 192.168.1.12. All these numbers should be less than 256 in value. In our small networks, the first two numbers would be 192.168. The third number specifies the network (A number for every network) and the fourth number denotes the system (a number for each system). IP address is relevant only in a working network. When a system joins a network, automatic IP address is allotted temporarily using the technique DHCP (Dynamic Host Control Protocol).

Compare the IP addresses of different systems. What are your findings?

- These are addresses temporarily assigned to systems when they connect to a network.
- IP addresses are dynamic; they change every time a system connects to a network.

The dynamic nature of IP address becomes inconvenient for systems that are permanently in a network. Every time you switch on the system, you have to check the new IP address. How can we resolve this problem? Naturally, the easiest way is to set permanent IP addresses for such systems. Let us see how this can be done.

**Setting Permanent IP Address**

**Activity 2**

Similar to what we did in Activity 1, right-click on the icon of the network monitor applet in the panel given at the

<table>
<thead>
<tr>
<th>Computer Number</th>
<th>IP address when the system was switched on the first time</th>
<th>IP address when the system was switched on the second time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>192.168.1.21</td>
<td></td>
</tr>
<tr>
<td>2.</td>
<td>192.168.1.___</td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td>192.168.1.___</td>
<td></td>
</tr>
<tr>
<td>4.</td>
<td>192.168.1.___</td>
<td></td>
</tr>
<tr>
<td>5.</td>
<td>192.168.1.___</td>
<td></td>
</tr>
</tbody>
</table>

Table 7.1
top and click ‘Edit Connections’. In the window that opens, select ‘Connections’ in the ‘Wired’ tab and click on the ‘Edit’ button (Picture 7.4).

![Picture 7.4](image)

A window appears. Select ‘Manual’ against ‘Method’ in the ‘IPv4 Settings’ tab, and click ‘Add’ button (Picture 7.5).

![Picture 7.5](image)

Address: 192.168.1.— (You may use any number from 0 to 255 here. Two systems in the same LAN should never have the same number).

Under ‘Netmask’ type 255.255.255.0. Provide the combination 192.168.1.1 under gateway and for DNS Server, and Apply (Save) (Picture 7.6).

![Picture 7.6](image)

When the window seeking password appears, provide the administrator password.

You may assign a permanent IP to each of the systems in the computer network in your school’s lab. Once you restart the systems, the new IP addresses would take effect. Examine and see. In short, the IP address of a system is either assigned by the network or by us according to our convenience.

What we have discussed so far was about the software settings for networking. Now let us examine the hardware components needed for networking.

**Hardware Requirements**

What are the hardware components used in networking the comput-
ers in our lab? Find out and complete the list below.

♦ Cables
♦ Adapter
♦ ...........................................................
♦ ...........................................................

Prepare detailed notes on each component. Some supporting information is provided below:

**Cables (UTP Cables – Unshielded Twisted Paired Cables)**

Take out and examine a cable with the help of your teacher (Picture 7.7). Remove its outer layer and see.

♦ How many wires are there inside the cable?

 ![Picture 7.7]

♦ Can you make these wires into pairs of the same colour?
♦ How many such pairs are there?

**Adapter Jacks**

♦ Did you notice the way UTP cables are plugged into the system?
♦ Did you notice the peculiar type of adapters used?
♦ These are RJ45 adapter jacks (Picture 7.8)

![Picture 7.8]

♦ How many pins (PIN) are there in RJ45 adapter jacks?

**Ethernet Card (Network Interface Card)**

Did you notice the component that links the network cable to the computer’s mother board? This component is called Ethernet card or Network Interface Card (NIC) (Picture 7.9). This can be used as an add-on card to the mother board. The motherboards that are available today have network interfacing cards integrated with them. Therefore, we do not have to add the card separately.

![Picture 7.9]

**Hub/Switch**

You know we can connect two computers using a cable. What if there are three or more computers? In that case it is not possible to connect the cables from different systems together. Therefore the cables are connected to a com-
Crimping

Crimping is the process of connecting connector jacks on both the ends of UTP cables. The tool used for this is called Crimping Tool (Picture 7.10). There is a specific order in which wires in a UTP cable are inserted into a RJ45 jack. RJ45 is held as shown in Picture 7.11 and wires are inserted in the order given below.

<table>
<thead>
<tr>
<th>Pin 1 - Orange White</th>
<th>Pin 5 - Blue White</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin 2 - Orange</td>
<td>Pin 6 - Green</td>
</tr>
<tr>
<td>Pin 3 - Green White</td>
<td>Pin 7 - Brown White</td>
</tr>
<tr>
<td>Pin 4 - Blue</td>
<td>Pin 8 - Brown</td>
</tr>
</tbody>
</table>

Wireless Networks

You must have seen some lap top computers accessing Internet without any cable. What is the technology used there? Have you thought about it? It is a technology called wireless network. Instead of cables, what are the data carriers used here? Are all the facilities of a normal network available in a wireless network too? Try to find out.

What are usually the systems in which wireless network is available?

- Some lap top computers
- ..........................................................
- ..........................................................

Is it possible to access wireless networks using desktop computers? What are the components needed for this? Find out.

Wireless Network – Components

Try finding out the components given in the pictures.
Activity 4

Is it required to permanently set IP addresses in wireless networks? What are the disadvantages of setting IP addresses this way?

Activity 5

What are the usual problems that the computer network in your school lab encounters? List them down.

Some of the systems in the lab cannot be shared over the network.

Activity 6

In the server in your computer lab, a cartoon film has been saved on the desktop with the file name foolfox.mpg.
How can you display this on the desktop of your computer? Proceed according to the steps given below.

♦ Open the Remote Desktop through System – Preferences. Tick ‘Allow Other Users to View Your Desktop’ and close the window (Picture 7.18).

![Remote Desktop Preferences](pic718.png)  
**Pic. 7.18**

♦ Repeat the same step on all the computers.

♦ Open the Remote Desktop Viewer in the Internet menu of your computer and click Connect.

♦ In the window that opens, select protocol VNC and type in the server’s IP address against Host.

♦ What does the window that appeared on the server system indicate?

♦ Aren’t you able to view the server’s desktop on your screen?

Try copying this file to your system. Does it allow copying? What is the solution for this?

### Sharing Files

#### Activity 7

Let us see what are the changes required in system for sharing files. In your system click in the order Places → Connect to Server. Connect to Server window appears. Provide settings in the window as shown in Picture 7.19.

![Connect to Server](pic719.png)  
**Pic. 7.19**

Select SSH as Server Type. Type the IP address of the system that we intend to connect against ‘Server’. Provide the Path of the folder to be connected against the tab ‘Folder’ (For example, in order to connect the desktop of user ‘its’, you should type /home/its/Desktop).

Now you can connect by providing the user name of the system that we intend to connect in the space provided for that.

You can select options according to the commands in the window that appears. In the slot for password in the next window, provide the password of the system that we intend to connect. Now you can connect the system.
Are you now able to copy the cartoon film from the server to your computer? What are the advantages of transferring files through network over transferring through gadgets such as pen drive? Complete the list below.

♦ You can copy to more than one system simultaneously.
♦ ............................................................
♦ ............................................................

Now let us see how computers in a network share a printer.

**Sharing Printer**

Suppose you have to prepare and print a model of an application form for registering students as members of the IT Club. Printer is connected to the server. You know that whichever computer you use to prepare the model, you will be able to print it from the server. How is a printer shared for this purpose? Do the activity described below to understand this.

**Activity 8**

♦ Activate the network in the lab

♦ In order to share the printer in the server, open the Printing window in the server using the route System – Administration – Printing

♦ Click Server – Settings. Tick all the check boxes in the window that opens and click OK (Picture 7.20).

Do the same processes in the machine that you use, open the model application form that has been prepared, and print it. Did you succeed in printing it?

The activities that you have completed just now have made you capable of using the computer network in the school lab effectively. There are lots more to understand about computer networks and the network of all networks – the Internet. We will do that some other time.

**Follow Up Activities**

1. Prepare a directory of hardware components used in networking with their photographs and descriptions.

2. List down the activities in the school that can use computer networks. Examine how these activities are performed as of now.

3. A permanent IP address has been set for a lap top computer using a wireless network. What is the major problem in doing so?

4. With help of Internet, analyse the ways in which computer networks are used in different sectors (Example: Banks, Newspaper companies)

5. The network monitor applet in the desktop of a computer used in your lab has disappeared. Find out how you can bring it back.
You have seen School wiki, Wikipedia, and the web site of the Government of Kerala and the Department of Education. Which are the other websites that you have visited? When you open a web site in a computer in the school lab, you are able to enjoy the pictures, films, and songs from some distant computer. How is this possible? In order to understand the principles and structure of websites, let us also build a website. We will first make a website which will be available only on the computer in your school lab.

Every website is a combination of web pages. You already know the method of preparing web pages using html tags. Tabulate the tags and their uses that you are familiar with in Table 8.1.

<table>
<thead>
<tr>
<th>Tag</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;html&gt;</td>
<td>for starting a Webpage</td>
</tr>
<tr>
<td>&lt;h1&gt;</td>
<td></td>
</tr>
<tr>
<td>..........</td>
<td>for make letters bold</td>
</tr>
<tr>
<td>&lt;marquee&gt;</td>
<td></td>
</tr>
<tr>
<td>..........</td>
<td></td>
</tr>
</tbody>
</table>

Table 8.1

Let Us Prepare

Let us build a website for presenting the various activities of our school for the public to view. You should do this in groups. Before preparing the website, we should plan how our schools’ website should be. For this, some tips are given below.

♦ How many pages should the website have in all?
♦ What should be the content in each of the web pages?
♦ Which groups will be responsible for preparing the different pages?

Use the model shown in Table 8.2 for effective planning.
File Structure

While preparing a website, you have to structure its contents systematically. We have to combine the web pages prepared by different groups to build the school’s website. Therefore it is necessary that all the groups prepare their contents in the same structure; be it images, motion pictures, or sound. Adopting a model shown in Picture 8.1 may be advisable for this.

<table>
<thead>
<tr>
<th>Group</th>
<th>Name of the page that the group will prepare</th>
<th>Names of sub-pages (if needed)</th>
<th>Content to be included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group 1</td>
<td>School athletic meet</td>
<td></td>
<td>* Events</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* Participants</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* Results</td>
</tr>
<tr>
<td>Group 2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group 3</td>
<td>Science Club</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Group 4</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 8.2

Activity 1

Each group should prepare web pages based on the topics assigned to them and save them in a folder titled MyWebsite. Include all the pictures in the folder titled Images. In order to include these picture in the web page, use the tag `<img src="images/Imagename.extension">`. It is better to specify the location of the picture in terms of relative path.

Relative and Absolute Path

There are two ways of inserting files containing images, sound, video etc into a website or while linking the webpage to a file. The Absolute Path of a file is the way of specifying the Folder Name and File Name starting from the file system. For example, suppose you want to insert the picture ‘sports.jpg’ in the images folder in MyWebsite folder into the web page. `<img src="/home/its/Desktop/MyWebsite/images/sports.jpg">` tag provides Absolute Path. Its Relative Path will be `<img src="images/sports.jpg">`. If Relative Path is given along with the tag, all links will work even if the system or location changes.
Adding Film in a Web Page

Adding a film on the web page that you have prepared will make it more attractive; don’t you think so? How do we include films in the web page? You have learned how to do video editing in previous classes. Shoot any activity in the school in video. Edit it as per requirement and save in a folder titled ‘videos’. For example, if the video you have prepared is say, ‘dance.flv’, by shooting the school youth festival, then the tag to be used will be <embed src="videos/dance.flv">. Embed tag can be used to add sound files too. Do try it out.

Kompo Zer for Building Website

You have practised preparing web pages using html tags. What were the difficulties you faced in preparing web pages that way? The tags needed for preparing a web site with several pages would be numerous. There are applications that help us build websites without using html tags. Such applications are called HTML Editors.

KompoZer, Quanta plus etc., are HTML Editors. Whatever we can do using html tags can be easily handled using these applications.

A Few Tips for Using KompoZer

For inserting pictures

Click on ‘Image’ tool in the tool bar and browse the image to be inserted. Then provide its name in ‘Alternate Text’ and press OK button.

For enlarging pictures

Click on the image; image size can be adjusted by manipulating the small squares that appear along the image boundaries.

For inserting titles

Type the text in and do the required formatting.

For hyperlinking icons/texts

Click on Link tool after selecting icons/texts. Then browse the file to be inserted and press OK button.

Inserting tables

Click on the Table tool and specify the number of rows and columns required. In order to format the table, right-click on the table and make the changes you want.

For arranging the page by typing in html tags

Click the ‘source’ tab below at the bottom of the window for preparing web page in KompoZer and make adequate changes.
Figure out the changes that you can make in web pages using KompoZer and tabulate.

♦ We can change font size and colour.
♦ We can give background colour.
♦ We can change the image size.

An Attractive Home Page for Our Website

Now that all the groups have prepared the web pages, let us assemble them to make our school’s website. You might have noticed the home pages of the websites that you have seen. Picture 8.3 shows the home page of the General Education Department’s website. We too need a home page for our website. Let all the groups observe a few web sites each and find out the various types of contents that they would like to include in the home page.

So, you have decided on what all need to be included in the home page?
Now let us construct the home page. Table 8.3 shows a layout that we can use for it. Include pictures and logos to develop your school’s home page. From the home pages that the groups have prepared, select the most attractive one as the home page for the school. See the instructions given in relation to this.

♦ Open a new page in KompoZer, assign Index.html as file name and save it in the folder MyWebsite.

♦ Click on Table icon and insert a table with three rows and three columns.

♦ For merging cells, select the concerned cells and click Table → Join Selected Cells. For example, for displaying the school’s name, we need to merge the second and third cells in the first row.

♦ In order to hide the table grid lines from appearing on the home page, select the table and take Table → Table Properties. In the window that opens set Border, Spacing, and Padding as zero in the table tab and press OK button.

♦ You can insert text and images by clicking on the cell.

♦ Link the web pages prepared by the groups to the home page.

Present the web sites prepared by the groups in a meeting of all the groups and select one from the best. Entrust this with the SSITC for building the school website.

To See the Website We Have Built

With the help of your teacher, post the website that you have built into the file system folder var/www. Then type localhost/index.html in the address bar of the web browser and press Enter key.
to view the home page of the web site. For this, there should be web server software installed in the system.

So, you have made the website work. Now discuss the arrangements to be made for making the website available on other machines in the lab. If you type the server’s IP address with /index.html in the address bar of the web browsers of other machines and press Enter key, the home page of the website will be available on those machines as well. For example, if the IP address of the server is 192.168.1.4, then in order to see the website in other machines, one has to type 192.168.1.4/index.html and press Enter.

**Activity 2**

Get the IP addresses of the server systems in which groups have saved their websites and observe them. Discuss the positive and negative aspects of the different websites and present a report.

---

**Server and Client**

Servers are computers that allow various programmes to be accessed by different users simultaneously. These are powerful machines with multiple processors set up for specific purposes. Here we will consider the system in which our website is saved as server and the other machines connected to it through the network as clients. Clients can also use the resources available with the server.

**Our Website on the Internet**

We could display the website that we prepared on other computers in the school lab. Can we display it on Internet so that anybody anywhere in the world can view it? There are two ways of doing this. One way is to make our computer (server) regularly available on
Internet so that anybody can watch it any time. Another way is to post our website in a web server set up to make the content available on the Internet. Once we do that, just as we could use the IP address of the server to see the website from other machines, others can see our website using Internet IP address or web address.

Before making it available on the Internet, compare your website with a few other web sites on the Internet. Won’t you like to make it more attractive? There are several tasks that require technical skills in building web sites (Compiling of web pages, designing). There are software applications that help you in these as well. They are called content management system software.

Let Us Start Building The Website

Let us improve the web site that we have built to overcome its limitations and make it available on the Internet for everyone to see. In order to do this, we have to first select a web content management system software. Drupal is a free and open web content management system software. This GNU GPL based software is the one that drives numerous websites in the world. All the features of commonly available content management system (CMS) software are available in Drupal as well. There is an option in Drupal Gardens which allows us to build a website without a web server and software installation. Let us see how we can build our website using this.

♦ Enter the website of Drupal content management system by typing www.drupalgardens.com in the web browser.

♦ Click on ‘create a free site’ button. In the window that opens (Picture 8.5), provide the URL that you want your website to have (web address), username for entering the website, password, and your current e-mail address.

♦ In the window that opens when you press ‘Continue’ (Picture 8.6), you can select the features that you want to include in your website.

♦ Features such as Comments, Mailing list, Webforms, Rotating banner, and Media gallery and Templates such as FAQ, Forums, Blog, and Contact Us are available here.

![Drupal Gardens](image-url)
Web Content Management System (WCMS)

Web Content Management Systems are software applications that help us in building websites, sharing information, making observations, and effecting controls in the web system. We can make attractive websites and manage the content easily using these applications. Some of the important WCMSs are Wordpress, Joomla, Drupal, LightCMS etc. The CMS software are installed in our computers (servers). Therefore we get the freedom to build websites on our own computers (server).

Several website templates are available in a web server in which CMS is installed. Select an appropriate template. Make changes in the log and colours to make it more attractive. Select the features that you want in the website (blog, user login, gallery, social network link etc.), insert information, pictures, and other documents; and your website is ready. You can make changes in the existing template whenever you want. The changes thus made will be reflected in the existing content.

Some WCMSs allow us to build our websites on their servers. www.drupalgardens.com, www.lightcms.com, www.wordpress.com, and http://sites.google.com are examples. Anybody with a e-mail address can open a website on any of these WCMSs.

From among these, let us include the features Media gallery, Blog, Contact us, and Abou. You can do this by clicking On/Off button. Press ‘Create’ and a website with the selected features would be ready.

In order to validate the e-mail address given at the time of web registration, you have to complete the registration process by clicking on the link that has been sent to the said e-mail address.

**Activity 3**

Prepare a website featuring this year’s activities in your school using Drupal gardens.
Making the Website Attractive

Now you have built a fairly attractive website with a reasonably good set of features. Now we can make changes, add new features, or make it more attractive.

Appearance

Once we log in to the website, the menu bar for making changes appears at the top (Picture 8.7). Select ‘Appearance’ menu from the menu bar for making the website attractive. The window that pops up (Picture 8.8) offers tabs such as Themes, Layout, Brand, and Styles which can be used to make the website beautiful.

If you think the default theme is not suitable for your website, there are several themes in different structures available here. Click on ‘Choose a new theme’ link and select another theme. You may save and keep the new theme by clicking on the Choose button and assigning a name.

Do you want to make any particular part of the website more attractive? For example, if you want to change the colour of the site header, click on the site header. As seen in Picture 8.9, in addition to showing the border of the selected block, ‘The site-name in the header region’ will be indicated in the in the tab titled ‘You are styling’.

The changes that you make now
will be felt within the boundaries of the selected block. You can select any block and modify the same way.

Even though the changes made in the web site get saved simultaneously, these changes will be visible to only us till we press the Publish button. Therefore click on the Publish button so that others can also see the changes (Picture 8.10). Once modifications are over, close the ‘Appearance’ window by pressing Close button.

**Activity 4**

Insert the school logo that we had
A Website for Us

prepared in Inkscape in the school website. Make adequate modifications to make it attractive.

**Enriching by Adding More Information**

Now we have a beautiful website. In a website what matters more than beauty is information content. It will become a good website only through timely display and renewal of information. Let us also enrich our website adding information on day to day events in the school.

**Activity 5**

In the school’s website, include information on the activities in the school, visits, digital objects prepared by students and teachers and information on excellence and achievements etc.

**Information to the Web Page**

As we had planned at the initial stage in the website building process, we have included pages for Home, About, Blog, Contact us, and Galleries. Now we have to provide the information needed in these pages.

What are the information available now in About page, which is expected to hold information on the objective of the web site and those who promote it. In order to make changes and to include more information, click ‘Edit’ menu below the About page title and include relevant information (Picture 8.11). (This menu appears only while you are logged in).

There are two editors available for adding information – HTML Editor and

**WYSIWYG Editor**

The abbreviation WYSIWYG stands for What You See Is What You Get. WYSIWYG Editor has a window and editing tools similar to that of a word processor. As the information added to this window is displayed as such on the web page, it is easier to work with WYSIWYG Editor for developing web pages.
Content Blocks

Different types of content included in a website are classified into blocks. Main menu, site logo, site name, Main banner, Main page content, and Search form are different blocks. We can also construct new blocks. We can fix the position of a block anywhere in the page layout. Navigation block (the link to all pages) can be positioned on the side bar or pre header.

WYSIWYG Editor (Picture 8.12).

Inserting an Image

Do you want to insert the pictures of important events in the school? We know that pictures make web pages more attractive. You can insert pictures by clicking ‘Add Media’ in the WYSIWYG Editor’s menu bar.

Media Gallery

Galleries help us exhibit a set of pictures thematically. Include the pictures of an event in which you have participated (art festival, study tour etc.) in the gallery.

We can go to the existing Gallery page by clicking the Gallery tab in the Navigation bar. Replace the sample gallery and pictures with the pictures you have with you. You can insert more pictures by clicking on the Add Media button.

Create a new gallery and insert the pictures that you have made in Inkscape and GIMP. For adding more pictures into this gallery, use Add Media button.

A New Page

You may need a new page to include descriptions of your participation in school events, study tour report etc. You can prepare new pages for each theme using ‘Content → Add Content → Basic Page’ in the menu bar.

Making Changes

You can modify or remove any of the contents (page, article, post) in the web site.

Changing Layout

There are several components in a web page including header, links to other pages, side bar, contents etc. Content management system prepares the appropriate layout for different types of contents. Typical page layout includes Pre header, Navigation, Banner, Pre-content, page content, Side bar, Pre footer, Copyright etc. However, we can modify the relative positions of any of the content blocks and change the layout.

Follow Up Activities

♦ Design the web page for displaying the activities of your school’s animation film production unit using html tags. Colour the letters and pictures to make it more attractive. Collect pictures, animation films etc and include them in the web page.

♦ Collect the web pages developed by students in different divisions and assemble them into a website.
Make the website beautiful by creating an impressive home page. Keep the website in a server so that all the machines can access it.

♦ Add information on school events and fairs to the website that you have prepared using Drupal Gardens.
You might have observed the gorgeous patterns that star constellations form in the night sky. Studying the inexhaustible treasure trove of wonders that the sky offers is really more fascinating.

Simulation software applications such as KStar, Stellarium, and Celestia offer us the opportunity to see and understand the celestial phenomena. You have familiarised yourselves with KStar software in Class VIII. Similarly, Stellarium is an application that allows us to study constellations in depth.

What about a sky expedition aided by this software? In order to do this, first you have to familiarise yourselves with the software.

- Open Stellarium from the Science Menu.
- When you place the mouse pointer at the left side of the main window, toolbar appears.
- Take the mouse pointer to the bottom of the window for Status bar.
- We can fix the status bar and tool bar in their positions, by clicking on the triangles at their intersecting point.
- Zoom in and Zoom out are possible using Page Up and Page Down keys or the scroll button in the mouse.
- Sightseeing in different directions is possible using Arrow keys on the keyboard.

"Long ago an Indian called Bhageerathan
Took away the holy river Ganga from the Heavens
And made it flow on the earth.
Tomorrow his descendents will jiggle with
The millions of celestial spheres".

-Vayalar Ramavarma-
Field of view (FOV) can be changed by dragging the mouse.

**Let Us Select the Observation Point**

We know that an eclipse – solar or lunar – cannot be viewed the same way from all locations on earth. Why is it so? Sky looks different from different points on earth. What we see depend on where we are looking from. So, where do we observe the sky from? Find out the observation point currently set in the software from the status bar.

Let us see how observation point is set in Stellarium software. By clicking the Location Tool (F6) (Picture 9.1.) given at the top of the tool bar we can reach the Location window. Click on the spot you would like to observe from on the map in the window (Picture 9.2). Now what you see is what is visible from the point that you have selected.

For repeated viewing from different points, we have to include observation points in the Location window. To fix location, we use latitude and longitude in KStar. For fixing locations, Stellarium also requires these. How do we get them? You have learned from previous classes that latitudes and longitudes can be found from Marble software. Collect the latitude and longitude of your place. Enter the values in the window. Note the way latitude, longitude, place name, and country name are recorded in Picture 9.2. (No need to make changes in the Altitude box). Click ‘Add to List’ button. Has the software added the location of your place in the window?

What is the name of the place appearing in the status bar now? Click the ‘Use as Default’ box shown at the
bottom of the window. Now your place has become the ‘default’ location. Whenever you open the software again, what you see would be what is visible from your location.

**Setting Date and Time**

What changes do we have to make in the settings to see the view of the sky at a particular time of the day? See the date and time recorded on the status bar (Picture 9.4). Date and time can be reset using the Date Time tool (F5) (Date/Time window) (Picture 9.3).

We know all the celestial orbs move. As they are so distant from the earth, their movement becomes noticeable only if we look carefully for a long time. But in the software we can enhance the speed of their movement by changing time speed. How can we change time speed?

We can enhance the speed of star movement in the software by increasing the time speed using ‘Increase Time Speed Tool’ in the time toolkit on status bar (Picture 9.4). With every click
on the time tool, time speed increases proportionately. You can get back to the system time by clicking Set Time to Now tool.

**Lines in the Sky**

What beautiful shapes do the imaginary lines that link the stars form in the sky! These shapes were found by our ancestors through continuous and careful observation of the sky.

Do the months in the Malayalam calendar have any relationship with the shapes of constellations? Have you observed Leo, the constellation with a lion’s shape? This constellation is known as ‘Chingam’. How can we locate Chingam constellation in the software?

- Type ‘Leo’ in the search window of the tool bar and click Searh.
- If they are beyond the field of view, bring them into the field by adjusting time.
- Using the three Constellation tools (Constellation Line, Label, Art) in the status tool bar, we can display the lines connecting the stars in a cluster, their names and their assumed shapes (Pic. 9.5).

- In order to display the stars in the sky during day time, use Night mode, Atmosphere tools in the status bar (Pic. 9.5).

**Around the Sun**

Earth’s trajectory around the sun is called its orbit. How do we mark orbit in the software?

Click Viewing options (F4) in the tool bar to reach View window. Clicking on Ecliptical line in the Celestial Sphere list in Markings tab will display the earth’s orbit (Picture 9.6).

Change months using Date/Time tool (Date/Time window). Observe the stars seen in the orbit every month in the background of the sun. Which are the stars other than those in Chingam constellation that are seen in the orbit in the background of the sun? Tabulate the constellations seen in the orbit (in the background of the sun) (Picture 9.7).
Star Formation

Orion is a constellation that attracts us due to its shape. Can you locate Orion constellation?

♦ Use search window to search for Orion.
♦ Use constellation tools to understand Orion’s shape.
♦ Are you able to see the shape of a hunter?
♦ Zoom in to the middle star among the three that form the ‘hunter’s sword’.
♦ For selecting an object use Left-click and for de-selecting Right-click.
♦ For Auto Zoom, select an object and press forward slash (/) button.
♦ For zooming out, use backward slash (\) button.
♦ For focussing on the object that is

Sunspots

Sunspots are dark spots seen in the sun. These are seen in the fields of intense magnetic activity within the sun’s photosphere. They are associated with strong magnetic fields and solar magnetic storms moving in a vortex. They look dark because they are cooler than the surrounding photosphere. It was Galileo who discovered sunspots in 1612. Zoom in to the sun to observe sunspots.
zoomed in, use ‘Centre on selected object’ tool in status bar.

How is this different from other constellations?

*Nebulae*

Nebulae (Nebula – Singular) are interstellar clouds of dust and gases. Stars form from nebulae. Try to locate the following nebulae and tabulate their properties.

- Eagle Nebula
- Garren Nebula
- Trifid Nebula

**The Pole Star**

The Pole Star (also known as Polaris or the North Star) has historically been used by sea farers to find direction. Why is the Pole Star useful in finding direction? Which constellation is the Pole Star part of?

Find the constellation called Ursa Minor (You can use Search Window tool (F3) in the tool bar). What is its shape? Polaris is the brightest star of this constellation (Picture 9.8). Move the stars faster by increasing the time speed. Don’t you see the Polaris remaining in the same spot while other stars change positions? What is the reason for the permanent position of Polaris?

**Length of the Day**

The position of Polaris is above the North Pole. Use the Location tool to set the observation point above the North Pole. (Click on North Pole in the map inside the Location window of the tool bar). Increase time speed. Now is it day or night in the North Pole? For how many days will it last? Do you notice the change in days in the status bar below? How is the sun’s movement? Move with the sun using Left and Right arrow keys. What do you observe? Observe the length of the day and the night.

*Black holes*

Stars is the final stages of their life evolve into Black Holes. Black Holes are characterised by extreme gravitational force. There are several mysteries about black holes that are yet to be revealed. Stephen Hawking is a contemporary scientist who has made significant contributions to the study of black holes.
Let Us Design Electronic Circuits

You have familiarised the simulation software called ‘FET Circuit Construction Kit’ used for constructing electric circuits and charging them in Class IX. Similarly, Ktech lab is a simulation software used for constructing electronic circuits and understanding them. This type of software helps us understand and improve electronic circuits without using real circuits. They also help in designing new circuits and testing them.

Two circuits constructed using Ktech lab are shown in Picture 9.10. What about making these circuits which are given in the chapter on electronics in your science text?

Open Ktech lab from Education menu and select File → New → Circuit. Click on OK button to open the main window for circuit construction (Picture 9.11).
power flow. In which circuit does current flow?

♦ How are the battery and diode connected in the circuit in which current flows? What type of biasing is this?

♦ Prepare a note covering the features of both the circuits.

Naming Components

Let us mark the names of the components that we have used in the circuit. For doing this, select Text from Draw tool and click at the place where the name is to be included. Double click on ‘Text’ to type in component names (Picture 91.2)

♦ Drag down battery, signal lamp (bulb), and diode from the components tab into the window.

♦ Drag the leads linking components using mouse to construct two circuits as shown in the picture.

♦ Any component can be removed from the circuit by selecting them and pressing delete.

♦ For changing the values of components, click on Item Editor and thereafter on the component.

♦ Construct the circuit and save it.

Identifying Features

Now that you have constructed the circuits, see the tips given below to analyse them. Use these tips to understand the features of the two circuits.

♦ Among two circuits, in which one does the bulb work?

♦ Settings → Configure Ktechlab → Animate wires to show current or

Pic. 9.11

Pic. 9.12
Saving Circuit Diagrams as Image Files

If you want to include the circuits that you have constructed in your blog or website, we have to convert them from Ktechlab into image files. Open the saved circuits in Ktechlab. Now use File → Export as Image, give a file name, and save. Haven’t we got the circuit as an image? Won’t you include this in your blog and website?

Activity 1

As shown in Picture 9.13, after connecting components, click on the oscilloscope and observe the waveforms. Construct the circuit and save it as an image file.

Make the following changes in the circuit and note down your observations.

♦ Connect a diode in the place where ‘diode’ is written and observe the changes in the waveform.
♦ Connect the diode in the opposite direction and observe the difference in waveform.
♦ Based on the changes in the waveform, discuss whether the change that occurred when the diode was connected is half wave rectification.
♦ Export the circuit as image file and keep it.

Activity 2

Construct a circuit as per Picture 9.14. Examine the oscilloscope and based on the graphs available in it, prepare a note on half wave rectification. Export the circuit as an image file.

You have understood how to construct electronic circuits and how to save them as image files. Similarly construct the other circuits that we have studied and observe their performance. Before actually constructing an electric or electronic circuit, we can make the circuit in Ktechlab and find out whether it works. Ktechlab can also be used to analyse the change in performance of the circuit when component values are changed.

Circles and Patterns

We have understood how to build a website in the previous chapter. Quite often we may have to include geometrical constructions in the websites that we build. We have practised making geometrical constructions in GeoGebra. Let us now understand how to include such constructions in a web page.
Let us prepare a geometrical construction for inserting into the web page. Draw a semi-circle. Examine the tool set available for drawing circles and locate the appropriate tool.

Note a point anywhere on the semi-circle that we have drawn. Now join this point with the two end points used for constructing the semi-circle. What is the measure of the inscribed angle?

Suppose we form another angle by marking another point in the semi-circle? What will be the angle size? What about another point?

What is your observation?

........................................................................................................................................

........................................................................................................................................

Is the geometric property that we observed applicable to all the points in the semi-circle? How do we examine this? We may have to draw angles for every point in the semi-circle and see. However, you can understand this without drawing angles for every point thanks to Geogebra. Select ‘Move’ tool from the first tool set in Geogebra window and move the point forming the angle and see.

Activity 3

Now what about an arc which is not a semi-circle? Draw it and observe.

Activity 4

Construct a circle. (Tool: Circle with centre and radius). Mark three points on the circle. Measure the angles formed by joining the points (Picture 9.16).

Now mark a point inside the circle. Join the end points of the angle to this point. Measure the newly formed angle as well.

What is the relationship between the measures of these two angles? If we shift the point inside to circle to the centre of the circle, what happens to the angle sizes?

Do not forget to save the file. What is the default file format?

Geometrical Patterns and Geogebra

Have you ever made patterns using geometrical shapes? It is possible to make such beautiful patterns using Geogebra. See the following example.
Construct a slider with values from 0 to 5.

- Draw a circle with the point on the line as centre and radius fixed by the slider.

- Mark the points where the circle intersects the line (Tool: Intersect two objects).

- Draw two more circles that pass through the central point; the circles should be drawn with the intersecting points as centre point in the preceding step (Picture 9.17).

- Press the right mouse button on the new circles. In the menu that unfolds, activate ‘Trace on’ option.

Now move the slider and see. What did you get? What happens if you activate the slider’s animation also? If required you may hide the first circle.

**Activity 5**

See the pattern in Picture 9.18. How can we make this? Some tips are given below.

- Mark two points on the plane (say A and B).

- Construct an angle at point A which
can be controlled by a slider. You may fix increment as $5^\circ$ in the slider.

- With the point obtained by forming the angle as the centre, draw a circle that passes through point A. Mark the ‘Trace’ of the circle when the slider moves.

Now move the slider and see. What if we draw the circle as passing through B instead of A? We will get another pattern. Can you find out the name of the pattern?

**Geogebra Applets**

You know that the default file format for saving the constructions made in Geogebra software is ‘.ggb’. However, for adding to a website, the format of the construction needs to be changed to ‘.html’ so that it can be inserted into a web page. While making this format change, the advantages of a Geogebra file should not be lost. Changing a file from its default format to another is called ‘Exporting’. That

**Geogebra and Drupal CMS**

Geogebra works based on Java programming. For the same reason, in content management systems such as Drupal that supports Applets developed in Java, the ‘jar’ files (Picture 9.22) need not be attached. Copying the programme codes of the construction will suffice. For copying the codes, the method shown in the picture below can be used.

Change File:html to Clipboard:html, take it to Clipboard, and copy to Drupal.

![Image](Pic. 9.20)

![Image](Pic. 9.19)
means we have to ‘export’ our construction as ‘.html’. See the Picture below. (File → Export → Dynamic worksheet as webpage).

Then we have to decide the Geogebra features that we want in the web page.

♦ If we want to add explanations above and below the construction in the web page, that can be typed in on the ‘General’ tab (Picture 9.21).

♦ Set length, width, and other parameters appropriate to the construction in the ‘Advanced’ tab.

**Exporting the File**

A construction made in Geogebra and exported to a web page is called Geogebra Applet. Picture 9.22 shows a folder containing certain Geogebra files, the web pages that contain the applets obtained by exporting the files, and supporting ‘jar’ files. Now you can provide hyper links from the home page of your website to these pages.

**Follow Up Activities**

♦ Are all the stars of the same colour? What is the colour of Betelgeuse? Locate stars such as Aldebaran,
Rigel, Spica, Arcturus and Betelgeuse and tabulate them based on their colour.

♦ Set location as Kottayam. Set the date to 8/11/2189 and time to 16.45.54. Observe the eclipse. Zoom in to the sun. Observe different views of the eclipse by changing time speed. Set location to Kanyakumari. Zoom in to the sun and observe the solar eclipse. Find out the changes in the planet positions.